COMException Class not registered for MQAX200.DLL

June 1, 2012 at 05:11:02
Specs: Windows 7
I created a application in 2005 Express edition, to send MQ messages using IBM Websphere MQ in Windows XP. I used the MQAX200.dll to import the MQ class libraries. The application worked fine in Windows XP. I have now changed my OS to Windows 7 and using 2010 I upgraded the application which was written using 2005. I installed the IBM Websphere MQ for Windows7 package and then referenced the latest MQAX200.dll to build the application in Windows7, using 2010

But now while initializing the MQsession during run time, I get the following exception:
Retrieving the COM class factory for component with CLSID {00290471-B893-11CF-A5F7-444553540000} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

I registered the dll using "Regsvr32" command and it was successful. Yet the error is not solved. Is there anything I missed to incorporate in the settings?

See More: COMException Class not registered for MQAX200.DLL

Report •

June 1, 2012 at 05:21:23
Make sure you're building your application as a x86 application, and not a x64 / any CPU application.

How To Ask Questions The Smart Way

Report •
Related Solutions

Ask Question