Solved DECWrite on OpenVMS 7.3: is it possible?

February 25, 2016 at 04:21:50
Specs: OpenVMS 7.3, VAX/64M
Is it possible to run DecWrite on OpenVMS 7.3 VAX? I know the XDPS library is missing, but that's only a warning level message. The application loads and runs, then vanishes without explanation.

See More: DECWrite on OpenVMS 7.3: is it possible?

Report •


#1
February 25, 2016 at 04:37:41
An alternative form of the question:

Can the XDPS$XDPSLIBSR.EXE file from OpenVMS 7.2 be copied to 7.3?

I don't actually need display postscript, but if that will allow the DECWrite application to run I could try to find someone who has 7.2 and would share the file.


Report •

#2
February 26, 2016 at 04:42:26
✔ Best Answer
GIven that OpenVMS is famous for compatibility, I would expect that any product installed on V7.2 would likely "work" when the system is upgraded to V7.3. I would not expect an installation to work however, it might so try it. If you can find it, check the SPD for DECWrite for information related to supported versions. If the only piece missing is that shareable image, it is possible that a copy would work. Please note however, that many shareable images like this need to be installed with some privileges for proper functioning. You may need to see how this library is installed on a V7.2 system and duplicate that for V7.3. As with anything not specifically supported, try it on a non-production system.

Also, look for a distribution kit (should be a CD or CDs) and unpack the installation saveset to extract the required file.

Dan


Report •

#3
February 26, 2016 at 05:03:23
Thanks, Dan. I should have given more detals on what I've already tried.

I'm working with a MicroVAX 3900 as simulated using SimH. The hobbyist licenses for OpenVMS do include DECWrite. I was able to obtain the installation kit for the product in its last released version, 3.1, and did install it as directed in the included documentation.

DECWrite appears in the menus of the X session manager after installation. When launched from a remote X server (Linux Mint) nothing seems to happen. However, when started from a DECTerm window with the command "run sys$system:decwrite.exe" an error message does appear:

%DCL-W-ACTIMAGE, error activating image XDPS$DPSLIBSHR.EXE

I've already been able to determine that this image and another, XDPS$DPSCLIENTSHR.EXE, were dropped after OpenVMS 7.3 and that they relate to display PostScript, which is no longer supported by most X servers.

It was already suggested to me that I just copy those two files from an OpenVMS 7.2 installation, but it probably will take considerable hunting to find an old installation or CD from which I could do that. What you suggest, that a 7.2 installation upgraded to 7.3 would still have the files and would allow DECWrite to run does sound likely, at least if no operation were attempted that required actual use of display PostScript.

Last night I tried faking the missing images by copying another shared library image (TPUSHR.EXE) to the names of the desired files. The theory was that DECWrite locates and loads the library images but doesn't call them until they are needed. This may be the case, as the application no longer issues warnings and quits. Instead it gets farther along and actually displays a new error on the X server screen, saying that it can't locate the fonts and asking the user to check WRITE$FONTS.INI. The latter file is in place, so now I have to puzzle out why it isn't being accepted.

In any case, I'll initiate a hunt for a working 7.2 system or a 7.2 installation CD as well. Thanks.


Report •
Related Solutions


Ask Question