Solved Libreoffice update to version 5.0.3 causes error 1935

December 4, 2015 at 02:00:13
Specs: Windows 8.1 64 bit, i7-5500U/2.4GHz/4GB
Libreoffice update causes error 1935...
LO no problems until I accepted the nag to update to version 5.0.3 from v502.. with hind site in a moment of madness.
I have uninstalled using CCleaner, ashampoo and win8.1 own uninstaller.. I also did a reg clean for possible problems, no luck.

Fortunately I had an old version of LO portable.
I installed and this was accepted with no roll back.

Less bells and whistles but enough to let me write formatted documents..

Any help from others will be greatly appreciated. ;-)

Bye Fred

See More: Libreoffice update to version 5.0.3 causes error 1935

Report •

December 4, 2015 at 03:07:16
How many versions of Visual C++ do you have installed?
If more than one, uninstall all old versions & keep only the latest.

Report •

December 5, 2015 at 11:48:13
Dear guru johnW, I had five old visual V++ and have left the most recent V 2010 dates feb 2015.
While I agree completely freeing disk space, later maybe some other prg, e.g protested will be needed.
Sadly the installation of LO installs about 7000 files and makes 8000+ reg entries until we get the progress indication that it is having problems with publish ????
Here we stop , error 1935 and LO decides it has to roll back everything and finalizes with "nothing has been installed" message.
I must add I have C18 compiler in MPlab to do a C project...
Before this present issue I have been working happily in LO and MPlab.
So John maybe knocking Visual C++ on the head has help some others but not for me.
Please accept my thanks for spending time thinking about error

Bye and Thanks

Report •

December 5, 2015 at 13:48:10
✔ Best Answer
"Dear guru johnW"
All I am doing is googling.

Libreoffice update causes error 1935

Try this way.
Installation of LibreOffice on Windows

Windows Installer error 1935

Some users get Windows Installer error 1935 and install rolls back. It may have caused by the broken setup of Microsoft Visual C++ 2008 Runtime on their computers. Windows installer of LibreOffice 3.5.4 and higher versions provide a workaround for this problem. Try to run LibreOffice Windows installer from the command line: msiexec /i LibO_3.5.4_Win_x86_install_multi.msi VC_REDIST=0. This will supress the installation of Microsoft Visual C++ 2008 Runtime that is embedded in LibreOffice Windows installer.
Cannot add LibreOffice MSI file to GPO

Some system admins tried to add LibreOffice Windows installer to GPO. They wanted to deploy LibreOffice from Group Policy. LibreOffice multi-language installer supports so many languages, that the list of Locale IDs is longer than 256 characters. This causes a problem for the GPO console, it reports that LibreOffice MSI file is invalid. There is a workaround:

Open the MSI in an MSI editor, for example in Orca.
Select View - Summary Information from the menu.
In Edit Summary Information dialog, go to Languages field.
Delete everything, keep only 1033 or the Locale ID of your choice. You can keep more, but lenght of this field should not exceed 256.
Press OK.
Save MSI.

Now you can add it to GPO.

Report •

Related Solutions

December 5, 2015 at 17:41:22
many thanks John but please don't waste anymore brain power on this stupid problem .
Now I'm a non technical windows user.
They keep on bombarding me with update to 'free' windows 10, implying it is infinitely better
What they don't say is most times when you jump to a new version a lot of programs in , for example XP just don't work any more in win 8.1. Some of them you couldn't care less, but maybe you mainstream donkey work programming applications don't want to know nor go.

Sorry I forgot to say I found the solution when I googled a more modern portable version
ºººººº LibreOfficePortable_5.0.3_MultilingualAll.paf ººººººººº

It does the lot ;-))

I'm dropping out . The LO 1935 quest is really for the Holy Grail
So to any other hotrod lady o gentleman ace please consider it may be window or Lo or the wrong .net framework.

My philosophy on software problems is if it works leave it alone.

Bye and a million thanks to you all.

Report •

December 7, 2015 at 08:14:16
I received the webmaster request to provide a best answer , which in view of the problem being intractable does not apply in this instance..
My own personal answer solves nothing.
I sidestep the error 1935 issue by in effect installing a different version of libre office. .

So sorry, error 1935 with LO is an enigma.
Bye and many thanks.

Report •

Ask Question