Solved error is coming while opening xlsx file

July 18, 2015 at 07:54:38
Specs: Windows 7
I have an application which exports data into .xlsx format. The excel file of format .xlsx is created through OpenXML. While trying to open it it gives error "Excel found unreadable content in (filename). Do you want to recover the contents of this workbook? if you trust the source of this workbook, click Yes." On click of yes file opens with another message giving log file of the repair. Once its opened, I save the file under some other name and now if I try to open the second file, it opens fine.

This only happens with Office 2010, with MS office 2007 its works fine. I even tried to create a small application (just to be sure is not related to my code) exactly same as in this link small application link . The issue remained same I was able to open the excel file fine in 2007 but in MS office 2010 it gave same error. I googled a lot but no answer. I cant change the file to resolve the issue once its created. I only need to make changes in the code to solve the issue. Please help

See More: error is coming while opening xlsx file

Report •

July 18, 2015 at 08:33:13
I do not use OpenXML but you might have better luck with your question here:

Only other thing, is to make sure you have the most up to date version.

Good luck


Report •

July 19, 2015 at 09:52:41
✔ Best Answer
I would recommend taking the Windows Updates back in and updating your spreadsheet software to support the new format. There are a few alternatives: reads both .xlsx and .xls, and is a free alternative to Microsoft Office
Microsoft may have released newer versions of converter plugins that allow Excel 2003 to read .xlsx
Wikipedia lists many others
Also you can look:

Report •
Related Solutions

Ask Question