Wrong IP and Subnet Mask issues

Microsoft Windows vista home premium w/s...
March 29, 2010 at 07:06:29
Specs: Windows Vista
Hi guys,

I'm running a USR 9106 ADSL router, I've configured it to allow DHCP on a subnet of in IP range, - 192.168.1. 100 only, recently a few people have come over to my house with their laptops and they have been unable to connect to my router they get limited connectivity, putting the machine on subnet and they cannot ping - the gateway / router. IPconfig release / renew does nothing. Each time this happens the person is running Vista. The Vista machines can see my router but they cannot get an IP - why is this? I've tried to manually assign an IP address and DNS, but this hasn't worked either. I have not configured my router to park machines on subnet of if there is a problem, so I've no idea where the machines are getting this from - additionally the IP address is NOT within the defined IP address range.

I've recently changed jobs and my new work laptop run XP and I've not had a problem connecting to my router.

Additionaly I've recently upgraded my 3 home laptop / desktop machines with Win 7 - fresh builds not upgrades - however the problem has only started since moving to Win 7. I've setup a 'Homegroup' for my machines as well and they never have a problem connecting. My sister brought her new 'pink' HP netbook over to show me, which runs Win 7, she had no problem with my router.

Can anyone offer some advice??
Has Win 7 got anything to do with the problem??

USR9106 ADSL Wireless Router - DHCP enabled.

See More: Wrong IP and Subnet Mask issues

March 29, 2010 at 07:28:45
The next time you try to connect one of these vista laptops, open a command prompt window and type the following command:

ipconfig /all

Post the output in here for us to look at.

Report •

March 29, 2010 at 07:32:36
Ok I can get my father-in-law to bring his over this weekend.

Can you give me a pointer on what I'm looking for??

Or is it simply to see the IP Address and subnet mask

Report •

March 29, 2010 at 07:38:41
This is a problem with Vista not the router. I have had similar problems with Vista trying to get it to connect a router, something that Windows XP would do without batting an eyelid.

The only way I could fix it would be to go through the whole network configuration from scratch as if it was a complete new install, something that should not be necessary.

On this particular machine I eventually ended up downgrading to Windows XP as Vista was PITA in many ways.


Report •

Related Solutions

March 29, 2010 at 07:43:15
Ok thanks. Any idea why it has only just started??

Was yours the same, Vista machine worked then stopped with this problem??

Report •

March 29, 2010 at 09:25:17
If you provide a ipconfig /all from one of the vista machines I believe the issue will become self explanatory.

Usual reasons for what you are experiencing are as follows;

windows firewall blocking access
static ip wkst assignment
if wireless connection wrong passphrase
connecting to another router in the neigborhood

Report •

April 3, 2010 at 11:23:51
Hi Guys,

This is from a Vista machine ...

Description: Intel Wireless Wifi Link
MAC Add: 00-1D-E0-6F-9D-A3
DHCP Enabled: YES
Autoconfiguration Enabled: Yes
IPv4 (Preferred)
Subnet Mask:
Default Gateway:

What is obviously wrong
Gateway should be
Subnet should be
IP Range is - 100

How do I correct this on a Vista machine?

Report •

April 3, 2010 at 13:09:17
What I've found is that for whatever reason, Vista tries to use IPv6 and if it can't get internet connectivity (because your router does not support IPv6) it auto assigns it's self an address of
To resolve this, go to the connection properties and UN-CHECK the box next to IPv6 and make sure that IPv4 is still enabled / checked.

It shoud work right away, but restart the machine anyway.
Please post back here what you find / what happens.

Report •

Ask Question