wireless capability is turned off, wlan is on

January 8, 2011 at 19:09:07
Specs: Windows 7, 64 bit, Intel t4500/4GB ddr2
We have a new HP G72 with windows 7. The wireless button turns the WLAN on and off, but the light stays amber, it is suppose to switch to blue. I still cannot connect to internet, troubleshoot and it says wireless capability is turned off. I have updated the driver, it is realtek rlt8191se, with 12/03/2010 software. I have tried uninstalling the device and reainstalling, still does not work. Went into the BIOS and enabled network adapter boot. Nothing in the BIOS about wireless. I updated everything else using the windows update to make sure that they did not have a fix. Windows mobility center says wireless is off but it will not let me select to turn it on. Other laptops are still able to see our wireless router, so it is not the router.

See More: wireless capability is turned off, wlan is on

Report •


#1
January 8, 2011 at 20:39:03
Some machines have a manual switch on the side or back of the case. Have you checked if yours has such a switch?

Goin' Fishin' (Some day)


Report •

#2
January 8, 2011 at 21:03:38
On my computer there is no switch. There is a wireless button that is suppose to enable and disable. When pushed the WLAN icon switches from enable to disable and back, but the wireless still does not work. I have ran the network diagnostic wizard and it cannot fix it either, that it was tells me that the wireless capability is turned off.

Report •

#3
January 12, 2011 at 23:33:59
So I figured the issue out myself. Even though this laptop was straight out of the box and everything should be fully installed. I powered off the laptop, took out the battery, and took off the cover for the wireless. I unscrewed the wireless card, took it out, sprayed canned air to clean out the slot, put the card back in and screwed it down. I put the covers and battery back on and turned on the laptop. VOILA the wireless was working. Will let everybody know if this stays fixed in a couple of weeks, as I have seen other posts where the problem comes back.

Report •

Related Solutions

#4
February 7, 2011 at 14:32:10
So it happened again, the fix only lasted a day, and taking out the card did not fix it this time. I purchased a new card and have had it in for over a week with no issues. So the wireless card was the issue.

Report •


Ask Question