Wireless Belkin router issue

August 16, 2011 at 13:09:22
Specs: Win XP home, sp3
Hi, I have a Belkin Router setup in my machine Win Xp, Home, SP3, Atheros AR5004G wireless Network Adoptor with a network authentication WPA2-PSK and Data Encryption - AES but as I try it to connect I receive the following error msg:
The network password needs to be 40bits or 104bits depending on your network configuration. This can be entered as 5 or 13 ascii characters or 10 or 26 hexadecimal characters."

The network key I keep entering is correct, and I'm unsure as to why it is not accepting the password???
I am sure I can connect my machine with different router, Netgear having WPA,WPA2-PSK setup with password protected without any difficulty and my machine works with wifi on. Pse note that no problem with wired connection Ethernet LAN.

But as I connect it with the Belkin Router, I get an annoying error msg as mentioned above.
I can't seem to figure it out and tired of getting it fixed. Please your help is much appreciated.


See More: Wireless Belkin router issue

Report •

August 16, 2011 at 14:05:55
If it were me, I'd reset that router back to factory defaults using the "reset" button in accordance with the apprvode method as detailed in the manua/setup guide.

After that, I'd reconfigure it and try again and see what results I got.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***

Report •

August 19, 2011 at 13:54:05
Thanks for your reply. As soon as I started having a problem with my wireless network adopter, my first step to get it right was to reset router but no luck and uncheck the authentication on wireless properties.
It still works with other routers with WPA-PSK based. The problem I encountered with is weird and nothing put it right. Now a message pops up saying window is unable to find a certificate to log you on to network. I carried out all troubleshooting but found no positive results.

What I did was I disabled existing wireless network adopter (driver)
and installed 802.11g belkin USB driver to get it worked. It worked for me with USB network adopter to connect my Belkin router. Though it is working for me with USB network adopter, I am still after the solution to my problem as this is not the right solution to my existing wireless network adopter. I am literally at a loss and don't know what the problem is.

Any comes up with the right solution would highly be appreciated.

Report •
Related Solutions

Ask Question