winxp network card and registry problem

Asus P4p800-mx desktop board
April 8, 2011 at 23:45:47
Specs: Windows XP, P4 3Gh 512Mb
Recently I ran into some very unusual problems and I'm hoping that someone might be able to give me some pointers as I'm fast running out of ideas.

Mobo: P4P800-MX with a 3Gh CPU and 512mb Memory (Hyperthreading turned on) 80Gb hdd. (I know it is old but I'm helping a friend and they can not afford a new system at the moment)

WinXp Home SP3

General problem: Suddenly no network connection, and the tcp/ip settings are greyed out. Network card has yellow triangle.

1) there is a Realtek 8101L LAN chip on board coming up as a Realtek RTL8139/810x Fast Ethernet NIC. It works if I boot from a Linux Live CD (ie I can reach other network resources and I can browse the internet) so I assume there are no hardware problems.
When I Boot from WinXp The network card is marked with the yellow circle with the explamation mark and says it does not work properly because windows can not load the driver (Code 31).
a) If I try to reinstall or upgrade the driver, the process always fails
b) If I try to remove the driver it fails with the message: "network card uninstall failed device might required to boot up the computer" but interestingly enough it actually gets removed
c) when I try to install from scratch (after that weird removal) it fails with the message: the string universal unique identifier (uuid) is invalid
I did all the steps I can think of:
I have cleaned up all the viruses with the help of Hijackthis, Autoruns, ProcessExplorer, Malwarebytes, Superantyspyware, Avg, SpyBot S&d (updated via USBKey) and for a good measure the Trinity Rescue Kit v3.4 Live CD (But I couldn't go the the internet to use Kaspersky online or similar)
I have cleaned the registry with CCleaner
I did "netsh winsock reset" and when it did not help I have deleted the winsock and winsock2 from the registry
I tried safe mode with the main user, and the administrator both.
I have also manually removed the device from the registry and tried reinstall with same faulty result.

2) In the process of all the above I have noticed that there are some wierd entries in the registry, under

Both cases the last entry is 4 squares
it can not be deleted and and permissions can not be set as there are no tabs on properties only the message that access denied.
when trying to right click.

When I inspect the registry with the PcRegedit Linux Live Boot CD these (sqare)entries do not show up.
I even went to the length of exporting out all the services registry entries and then matching them up to the registry one by one, and that one entry with the squeres in both controlset do not show up within the exported entries.
At one time I was able to look inside one of the "squares" entry in the the controlset I was not logged in with, and it turned out to be the same as the [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\NwlnkFlt] key but when i tried to rename it, it said that the key "already exists" and sure enough I was able to find it in the list. So I assume that the registry is corrupted.

Otherwise everything else seems to work, except I can not use the network card.

I was hoping to avoide a repair install as it has its own risks and I consider a drastic step, and I'm hoping someone might has a better idea.


See More: winxp network card and registry problem

Report •

April 9, 2011 at 19:20:51
Did you install the motherboard drivers first then the nic drivers?

Report •

April 9, 2011 at 20:14:45
The NIC is on the MOBO.
There are only 4 drivers dowloadable from asus: Audio, LAN, RAID and VGA
Audio and VGA works and RAID is not needed.
The Problem is with the LAN driver.

Report •

April 10, 2011 at 04:59:58
Have you tried loading any of the other drivers? Depending on how they were developed they may be some dependencies.

Report •

Related Solutions

April 10, 2011 at 14:24:23
Yes, I tried.
Every other driver installs with no problems.
I even have found an actual MOBO chipset driver under the Utilities Subsection on the ASUS website and after getting rid of the faulty NIC driver again, I tried to run the chipset driver, which have installed with no problems whatsoever, but trying to install the NIC driver failed again...

Report •

Ask Question