Windows could not detect this network's proxy settings

February 11, 2017 at 10:07:10
Specs: Windows 64
I lose connection to the internet for about ten seconds once every five minutes or so. When I run the troubleshooter from the control panel it says "windows could not automatically detect this network's proxy settings." I have been trying solutions to this for weeks and nothing has worked.

First I made sure I wasnt using a proxy, and that it was set it to "automatically detect settings". Then I tried a number of commands, including netsh winsock reset and netsh int ipv4 reset, neither of those worked either. I also did a network reset.

I thought perhaps I had some kind of malware so I ran several malware scans and didn't find anything. Then I disabled all the antivirus programs and firewalls to see if that was the issue. After that still didn't fix it, I did a full reset on my pc, and even that didn't work.

I don't have this problem on my other devices that are connected to the same network. This leads me to believe it could be a hardware problem, like with my wifi card or something but I'm not sure. Any solutions would be much appreciated


See More: Windows could not detect this networks proxy settings

Report •

#1
February 11, 2017 at 13:23:18
Please run this small freebie which is focussed on browser malware:

AdwCleaner:
https://toolslib.net/downloads/view...
(blue "Download Now" button on right).
Download and "Save" the file somewhere. Go to the saved file then double click it to run the program. Use the "Scan" button, followed by the "Clean" button.

If it finds anything please copy/paste the log on here (it is in ADWCleaner folder right off the C drive).

Always pop back and let us know the outcome - thanks


Report •

#2
February 11, 2017 at 13:41:33
It detected some of my chrome extensions as threats and I used the clean button but I'm still having the same issues

heres the log:
# AdwCleaner v6.043 - Logfile created 11/02/2017 at 16:28:39
# Updated on 27/01/2017 by Malwarebytes
# Database : 2017-02-09.1 [Server]
# Operating System : Windows 10 Home (X64)
# Username : Nick - DESKTOP-D0BNFUB
# Running from : C:\Users\Nick\Downloads\adwcleaner_6.043.exe
# Mode: Clean
# Support : https://www.malwarebytes.com/support

***** [ Services ] *****

***** [ Folders ] *****

[-] Folder deleted: C:\Users\Nick\AppData\Local\Google\Chrome\User Data\Default\Extensions\nonjdcjchghhkdoolnlbekcfllmednbl


***** [ Files ] *****

[-] File deleted: C:\Users\Nick\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\Driver Booster.lnk
[-] File deleted: C:\Users\Nick\AppData\Local\Google\Chrome\User Data\Default\Local Storage\chrome-extension_nonjdcjchghhkdoolnlbekcfllmednbl_0.localstorage
[-] File deleted: C:\Users\Nick\AppData\Local\Google\Chrome\User Data\Default\Local Storage\chrome-extension_nonjdcjchghhkdoolnlbekcfllmednbl_0.localstorage-journal


***** [ DLL ] *****

***** [ WMI ] *****

***** [ Shortcuts ] *****

***** [ Scheduled Tasks ] *****

***** [ Registry ] *****

***** [ Web browsers ] *****

[-] [C:\Users\Nick\AppData\Local\Google\Chrome\User Data\Default] [extension] Deleted: nonjdcjchghhkdoolnlbekcfllmednbl


*************************

:: "Tracing" keys deleted
:: Winsock settings cleared

*************************

C:\AdwCleaner\AdwCleaner[C0].txt - [1456 Bytes] - [11/02/2017 16:28:39]
C:\AdwCleaner\AdwCleaner[S0].txt - [1739 Bytes] - [11/02/2017 16:26:35]

########## EOF - C:\AdwCleaner\AdwCleaner[C0].txt - [1602 Bytes] ##########


Report •

#3
February 11, 2017 at 15:02:11
In view of what it found please run these two freebies as well, in the order given:

Junkware Removal Tool (JRT)
https://www.malwarebytes.org/junkwa...
(blue Download button).
Download and "Save" the file somewhere. Go to the saved file then double click it to run JRT. It might appear to have stopped at times or flash the screen but sit tight until it has finished.

MalwareBytes:
https://www.malwarebytes.org/
(use the "Free Download" button rather than the "Buy Now" button).
After the install go to "Settings > Protection". Under Scan Options move the "Scan for rootkits" slider over to On and Run the Threat Scan. Quarantine anything it finds.

If they find anything please the logs on here as before. The ADW log is a text file in the ADWCleaner folder directly off the system drive root (usually C).

Always pop back and let us know the outcome - thanks


Report •

Related Solutions

#4
February 11, 2017 at 16:06:06
Still not fixed. I think the log is saying the program driverbooster is a problem, but I've been having this problem long before I installed that. Also, Malwarebytes didn't detect any threats

Log from the first tool:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Junkware Removal Tool (JRT) by Malwarebytes
Version: 8.1.0 (12.05.2016)
Operating System: Windows 10 Home x64
Ran by Nick (Administrator) on Sat 02/11/2017 at 18:05:52.64
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


File System: 3

Successfully deleted: C:\ProgramData\productdata (Folder)
Successfully deleted: C:\Windows\system32\Tasks\Driver Booster Scheduler (Task)
Successfully deleted: C:\Windows\system32\Tasks\Driver Booster SkipUAC (Nick) (Task)

Registry: 0

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Scan was completed on Sat 02/11/2017 at 18:07:16.60
End of JRT log
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

message edited by Deadprez


Report •

#5
February 11, 2017 at 16:18:32
OK. Programs like Driver Booster are often deprecated but I doubt that is your issue.

What operating system are you running. I'm assuming it is the 64 bit version of something?

I assume you've tried shutting off your router for half a minute?

"I did a full reset on my pc"
Do you mean factory restore or something else?

Always pop back and let us know the outcome - thanks

message edited by Derek


Report •

#6
February 11, 2017 at 17:42:32
Im running windows 64 bit. Yes I did a full factory restore so I highly doubt there's any malware. I have indeed tried resetting my router

Report •

#7
February 11, 2017 at 18:54:06
what version of windows 64 windows 7 or windows 10?

Davidw


Report •

#8
February 11, 2017 at 19:12:05
As per #7. There is no such thing as "Windows 64". There are 64 bit versions of various operating systems, such as Windows 7 and Windows 10.

Always pop back and let us know the outcome - thanks


Report •

#9
February 11, 2017 at 19:17:51
Im running windows 10

Report •

#10
February 12, 2017 at 04:32:00
Thanks. Seems then it is down to one of two things, either hardware or a network adapter driver. Hard to imagine this is a hardware issue.

Did you have Windows 10 from day 1 or was it an upgrade from Windows 7?

Have you checked to see if you have the latest network driver from the computer manufacturer? I don't trust those driver finding programs.

Always pop back and let us know the outcome - thanks


Report •

#11
February 12, 2017 at 16:57:00
A number of possible network fixes:
https://support.microsoft.com/en-us...

Report •

Ask Question