Solved Why do PC's resolve to public IPs on my net?

January 2, 2011 at 19:04:39
Specs: Windows 7, Intel Core 2 Quad 2.5ghz/8GB Ram
I have an issue with name resolution on my home network. Computer names are being resolved to public ip addresses instead of to their private ip address.

My home network consists of a Motorola Surfboard Cable Modem, a Belkin Surf N300 wireless router with the latest firmware, two PCs with 64-bit Windows 7 Pro, one PC with WinXP SP3 and a D-Link DSM-520 Media Player. All the computers are connected to the router through cable. The DSM-520 is connected via wireless.

DHCP is enabled on the Belkin router. The Local Domain Name setting in the Belkin's LAN Settings is "colt" The host files on the PCs contain only comments.

My Win7 PC's name is alshotasus, my wife's Win7 PC's name is ellenshotpc. The WinXP system's name is gw-mediapc.

According to the DHCP Client list in the Belkin router the router has assigned these ip addresses:


But, when I ping gw-mediapc (or gw-mediapc.colt) from alshotasus, ping reports the ip address as

C:\Windows\system32>ping gw-mediapc.colt
Pinging gw-mediapc.colt [] with 32 bytes of data:
Reply from bytes=32 time=61ms TTL=112
(Note that sometimes the ip address returned by ping is a different public address.)

When I ping ellenshotpc (or ellenshotpc.colt) ping reports the ip address as
(Sometimes the ip address returned by ping is a different public address.)

Curiously, when I ping my system, alshotasus (or alshotasus.colt), ping reports the ip address is the same as for ellenshotpc:

Here's the output from ipconfig when run on my PC:
C:\Windows\system32>ipconfig /all

Windows IP Configuration
Host Name . . . . . . . . . . . . : AlsHotAsus
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : colt

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : colt
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : 00-26-18-E1-82-92
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Lease Obtained. . . . . . . . . . : Saturday, January 01, 2011 7:26:45 AM
Lease Expires . . . . . . . . . . : Tuesday, February 07, 2147 4:50:58 PM
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . :
DNS Servers . . . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.colt:

Connection-specific DNS Suffix . : colt
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::5efe:
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:2c35:2473:e719:752f(Preferred)
Link-local IPv6 Address . . . . . : fe80::2c35:2473:e719:752f%13(Preferred)
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled

Here's the output of nbtstat -c

Local Area Connection:
Node IpAddress: [] Scope Id: []

NetBIOS Remote Cache Name Table

Name Type Host Address Life [sec]

Note that the ip addresses reported by nbtstat are identical to the ip addresses in the Belkin router's DHCP client list.

This name resolution issue started after I replaced an old Linksys BEFSR41 with the Belkin N300. I discovered the issue the first time I tried to connect with Remote Desktop by computer name. Now, I have to use the remote PC's ip address in order to connect with Remote Desktop.

Can someone explain what is going on with name resolution on my network and help me fix the problem?


See More: Why do PCs resolve to public IPs on my net?

Report •

✔ Best Answer
January 26, 2011 at 12:05:43
I had the same issues with my Belkin N300 router, a Christmas gift. Modifying the DNS entries to and fixed the problem. I am now able to resolve local hostnames correctly. Thanks!! I didn't have this problem with the Linksys G router that this replaced.

Al, Did you ever hear back from Belkin?

January 2, 2011 at 21:56:45
You are adding to the machine name which does not exist locally so the name resolution request is being set to the internet per your gotten responses.

After all .colt isn't your domain name. As said over on social microsoft leave the domain name/suffix blank or use .local.

Answers are only as good as the information you provide.
How to properly post a question:

Report •

January 3, 2011 at 04:41:39
Thanks for your reply. I tried .local just now, followed by an ipconfig /release and then a /renew. ipconfig /all confirms that the Connection specific DNS suffix is now .local. The results are the same. The names still resolve to external addresses.

The Belkin N300 Lan Setting page doesn't allow a blank Local Domain Name. Is there somewhere else I can configure my system to not append the Local Domain Name to the host name?


Report •

January 4, 2011 at 04:32:30
When I set the Local Domain Name field in the Belkin router Lan settings screen to empty and apply the change the router always sets it back to the previous value. The router allowed me to change belkin to colt and colt to local, but it doesn't seem to allow an empty Local Domain Name. I've submitted a tech support question to Belkin asking how to set the Local Domain Name to empty.
While I wait for Belkin Tech Support to respond, do you have any other ideas I can try?


Report •

Related Solutions

January 4, 2011 at 06:01:11
From the sounds of what's going on this could be a minor glitch with your router.

If your LAN is working properly....
If your internet is working properly.......
If your clients can ping each other by IP address properly......

Then you don't really have a problem.

As wanderer said, when pinging by hostname, do not include a domain suffix, ping only the hostname:
ping alshotasus

Does it reply properly and return the correct IP or not?

If it does, then the router is trying to resolve the FQDN you were trying to ping and since you don't have a domain, it's looking on the internet.

So, what IP address shows when you ping only the hostname?

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***

Report •

January 4, 2011 at 16:17:16
Hi Curt,

Thanks for joining the discussion. I suspect you are correct that the problem is caused by a minor glitch in the router.

pinging the hostname returns the same ip address as pinging the hostname+domain name suffix. For example, just now I ping'ed ellenshotpcand I ping'ed ellenshotpc.local I also ping'ed ellenshotpc. (note the terminating period after the hostname). All three resolved to an ip of

Truth be told, I'm not that concerned about the hostname+domain name suffix resolving to the wrong address since I rarely use hostname+domain name suffix. My greatest concern is with the fact that the hostname resolves to the wrong ip address since the hostname is what I prefer to use in the Remote Desktop Connection dialog.

I realize that I can work around this problem by using the ip address instead of the hostname (or possibly by assigning static ip's to my pc's and setting the names in the host file) but I would prefer to identify the cause of the problem in hopes that it leads to a real fix.

Any insight you can offer will be appreciated.

Report •

January 4, 2011 at 16:25:19
remove all references to a domain name.

then do a nslookup ellenshotpc and post the results

Answers are only as good as the information you provide.
How to properly post a question:

Report •

January 6, 2011 at 04:24:38
As far as I can tell, the only reference to a domain name is in the Belkin router's LAN Settings screen. Although that screen allows me to change the Local Domain Name from one name to another (e.g., "belkin" to "local"), it does not allow me to change the domain name to an empty name (i.e., no characters). I have submitted a help desk question to Belkin Tech Support asking if it is possible to set the Local Domain Name to an empty string and if so, how to do it. No response, yet.

On my PC, I have confirmed the Local Area connection TCP/IP Settings dialogs contain no domain names. The "DNS suffix for this connection" field is empty and the "Append these DNS suffixes (in order)" list is empty.

Is there some other place besides those I listed above that I should check for a domain name?


Report •

January 6, 2011 at 05:47:15
If you're not seeing a domain name in the TCP/IP settings then there isn't one locally on your PC.

I'm pretty sure the issue is your router.

When you type a hostname in on your PC, it goes to your router for resolution. If it can't resolve it locally then it forwards the DNS request out onto the internet to a higher level DNS server for resolution. In your case, they should never get beyond your router since they're local hosts on the LAN.

Have you checked to see if there's a newer firmware for your router available? If not, you should do so and then apply it if there is one. This could be a known bug that they've fixed in a more recent firmware version.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***

Report •

January 7, 2011 at 18:18:20

Yes, I've verified that I have the latest version of the firmware for the router.

I think the most likely cause of the problem is the router, too. Today, Belkin tech support informed me that it is not possible to have an empty Local Domain Name in the Lan Settings in the router. I suspect that's part of the problem. I found someone posting on that said that his Belkin router was not handling name resolution properly. He said: Also, it can't handle dns requests properly. Any PC on my home network that it supplies a DHCP address routes all private dns requests to my ISP.

On the other hand, maybe the problem is not with the router but in the Netbios name resolution. From what I've read recently it seems that when I do something on the computer that causes the system to need to resolve "ellenshotpc" or "gw-mediapc" it needs to do a Netbios name resolution since the computer names are actually NetBios names.

Or, maybe the problem is with LLMNR.

I don't know. In the last week I've learned that name resolution on a home network with Win7 can be very complicated.

I'm going to put WireShark or Ethereal on my system and see just what is happening during name resolution.

Report •

January 7, 2011 at 18:53:52
My Guess -

Your router is using OpenDNS or some other crappy service w/ a wildcard DNS entry for advertising.

Go to those IP addresses in a browser - ,

They're both lameo portal websites.

This explains the local resolution problem too, because DNS is queried BEFORE NetBIOS (per: )

So what's happening -

1) Node sends DNS query for whatever.local
2) Router/dns proxy responds with a bogus wildcard entry
3) Node never tries NetBIOS, so local resolution never works.


Check in your router's config, can you specify the DNS server? Use Google's:

Or if not, just set those DNS servers on your local machine & see if that fixes the problem.

Report •

January 26, 2011 at 12:05:43
✔ Best Answer
I had the same issues with my Belkin N300 router, a Christmas gift. Modifying the DNS entries to and fixed the problem. I am now able to resolve local hostnames correctly. Thanks!! I didn't have this problem with the Linksys G router that this replaced.

Al, Did you ever hear back from Belkin?

Report •

January 28, 2011 at 03:59:05
Belkin support said they will ask their engineers if it is possible to enhance the router to allow empty Local Domain Names, but they offered no real solutions with the current firmware.

I must admit that I have not tried changing the DNS settings to use and I took the easy way out by using static IP's on my computers with HOST file entries for name resolution.

I will try to find the time this weekend to test and and report back.

Report •

January 28, 2011 at 07:57:01
rvl9267's solution is a false positive. Local name resolution is NEVER handled by internet dns servers so pointing to Google's public dns [] had nothing to do with local name resolution working.

Local name resolution, with no lan dns server, is done by broadcasts and then stored by the local workstations dns resolver.

Using a hosts file is a sure fire way of taking care of local name resolution.

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's

Report •

January 29, 2011 at 05:52:51
I experimented with and for DNS (after removing all PC entries from the HOSTS file) and it did not fix the problem. I've reverted back to using the HOSTS file for local network name resolution.

My thanks to everyone for their input.

Report •

January 30, 2011 at 22:27:50
I had the same problem with my N300. I set the DNS to the Google Public but still had the same problem. I figured the wildcard thing was definantly part of the
problem since my public web site sometimes resolves to an add when I leave the www off. I finally got it to work by changing the domain to "localhost" AND the DNS to the Google servers ( and
Hope this works for you too... Let me know if you have the same results or if I just got lucky.
See next post.............. It was luck but I figured out how I lucked into it!

Report •

January 30, 2011 at 23:18:32
After experimenting a bit more...It seems to work for me now with any domain name. Maybe you need to just change the domain to something different after changing the DNS???? Did you change the DNS settings in the router or in your computer? I changed mine in the router but it didn't start working till I changed the Domain to localhost... now it doesn't seem to matter what domain I use in the router the local ip addresses still come up correctly when I ping and the local names work for my Remote Desktop now too....
I then did a bit more experimenting and found that what you need to do is restart the router from the router setup page after changing the DNS entrys to the Google servers. Changing the DNS doesn't reboot the router while changing the Domain does.... This is why changing the domain to "localhost" made the local ip lookup work. It wasn't the name I used, it was the fact that I changed it which caused a reboot.

Report •

January 31, 2011 at 01:06:35

rvl9267 was not a false posative!!! Since the domain is required the effect is that you are trying to resolve localhost.domain and not localhost. This makes it a host name lookup and not a netbios lookup. If you read fmwap's post and the MS article noted it says that in this case the HOSTS file is searched then the DNS. The local lookup never gets to happen because the DNS returns something first. If the DNS server contains domains that are setup with wild card entrys then it can get a return from the DNS server even if nothing is found in the DNS. The google server is not set up to allow this to happen and as a result the lookup eventually gets returned and is looked up locally.
Readup.... "A wildcard DNS record is a record in a DNS zone that will match requests for non-existent domain names."

Report •

January 31, 2011 at 01:31:02
Sometimes all the information in the world cannot provide the correct can even hinder the process! There is no one correct way to ask a question...What is correct depends on the person being asked as well as the person asking. In other words it requires communication not just information..... Peace

Report •

January 31, 2011 at 04:18:09
When I tried using and I entered them in the DNS config on my PC, not on the router. I may try using Google's DNS in the router next weekend. If I do, I'll let you-all know the details and the results.

Report •

January 31, 2011 at 06:05:15
Be sure to reboot the router after making the change as it has no effect till you do so. Also...It should have worked to change the DNS in your computer but just for that machine, not the whole network... I just reset my router to auto DNS did a local ping and got the weird public IP returned, then went into the settings for DNS in the TCP/IPv4 on my wifi card and changed them to the google ones, pinged again and got the correct local ip. You may have to release and renew or reboot....(I didn't)... Are you sure you changed the DNS for the same adapter your connecting with? You can have a different DNS for each adapter and different dns for IPv4 and IPv6 on the same adapter to make it even more fun!....and the 2nd Google DNS IP is not
Good Luck!

Report •

January 31, 2011 at 07:45:29
Here is a good read on how the google dns servers handle nonexistent domains.

By adding the requirement of the domain name in the belkin router when you do a ping for a localhost you actually are pinging localhost.domain if this were able to be left blank the result would be a ping for just localhost... Wanderer is correct the local name resolution gets done locally but with the domain addded it is considered non local since the computers don't belong to the same domain and is therefore resolved by DNS if not found in the HOSTS file. Since localhost.doman does not exist you should get returned and then the name would be resolved locally. Instead what happens is a form of "NXDOMAIN hijacking"; through the use of wildcards you get redirected to an add. I suspect adding the same domain to the setup of all computers in the network would get the local names to resolve correctly too but that is a bit too much work just for the sake of experiment.

Report •

January 31, 2011 at 09:00:11
Thanks for the extra info and thanks for correcting me on Google's second DNS address.

I'm certain I changed the DNS address for the correct adapter. In regards to IPv4 vs IPv6, I disabled IPv6 when I first started investigating this problem and never turned it back on.

I will be sure and reboot the router when I test again.
- Al

Report •

February 6, 2011 at 15:40:03
I retested using Google's public DNS servers today. I'm happy to report that it resolved (word play intended) my problems. Here are the details on the test.

1. I turned off my wife's Windows 7 PC.
2. I changed the IP configuration on my Win7 PC and my WinXP PC so they got their ip address and other IP configuration info from the DHCP server on the router.
3. I changed the router's DNS configuration to use Google's DNS servers ( and and applied the changes to the router.
4. I commented out all of the entries in the etc\hosts files on my Win7 PC and the WinXP PC.
5. I Rebooted my Win7 PC and my WinXP PC.
6. I forgot to reboot the router and I didn't change the local network domain name in the router settings. It is still "local".

After logging into my Win7 PC and my WinXP PC I was able to ping both systems from each other. Each system's name was correctly resolved to the IP address assigned by the router's DHCP server.

I was also able connect to the WinXP system from my Win7 PC with Remote Desktop.

Next I turned on my wife's Win7 PC and changed its networks settings to use DHCP and I commented out all entries in the etc\hosts file. I logged off as administrator and logged back on under my wife's account.

Name resolution works correctly with each PC on my network now without having to use static IPs and host file entries. I'll continue to run this way unless Google decides to take down their public DNS servers.

Thanks for your help everyone.

Report •

August 28, 2011 at 10:51:08
Thanks to all of you. I recently purchased a Belkin N750 DB wire/wireless router. The issue you helped me resolve has to do with my Sonicwall GVC connection to the office. I was getting that weird domain name issue when trying to connect to any of the four server I have to monitor and manage as well as the console PC attached to them. Company is a little to cheep to by HMC. Blanking out the local domain name in the router fixed the problem is netbios names resolving. I already knew about Google DNS's. I don't know what it is about isp's but when they keep changing the DNS server the network is connected to I inevitably have issue or problems with connectivity. So we have been slowly as individual PC have issues, defining DNS server local for the adapter. Yep, we have been setting them to Googles. It's amazing more DNS server don't function like goodles or at the very least adopt google standards. Finding this post saved me from having to deal with Belkin Techsupport for a second time. If this has been a reported issue to them, they should have known what my issue was. However, they did not.

Again many thanks to all of you having this issue and the very helpful advise given by other more knowledable then I. Networking is not my primary fuction, but one of many. So from a System Analyst/Programner to all you techies. Thank you. You have increased my knowledge and provided me with a solution that keeps me working. Working = Keeps me employed. :-)

Report •

Ask Question