Virus/fix caused me to lose internet, Unable to renew IP

December 26, 2011 at 18:50:49
Specs: Windows XP Professional
A few days ago a netbook I was using, EEE PC 1000HE, picked up a virus pretending to be a virus protection system. I didn't buy it for a second of course. "XP Security Center", well I couldn't get Malware Bytes to run so I was desperate. Someone on a non-tech forum told me to run Combofix.... I didn't do any research first... I was stupid.

Combofix destroyed the virus but, well, other things too I think.

Now the TCP/IP is fouled up. The DHCP thing doesn't work at all. It simply says it cannot renew the IP address. This applies to wireless and wired connections. I went to the services list and the DHCP thing refuses to be enabled.

I am at my wits end. I have tried a fixit patch from Microsoft and nothing happened. I tried a registry fix utility and no luck. Seriously I don't know if this is the root of the problem or just a symptom.

This is a borrowed netbook, I cannot reset it because of all the stuff it contains. I really need to get the internet working again. Oh the router is not the problem, there are other computers, xboxes, iphones and stuff using it all the time. I am not sure I am even explaining it properly.

See More: Virus/fix caused me to lose internet, Unable to renew IP

Report •

December 27, 2011 at 10:32:51
Okay, there might be a couple ways to fix this.

Go into internet explorer>tools>internet options and look at connections. If there is a port address in there, remove it and disable the network connection and enable it again. Some viruses use other internet ports to transmit/receive information.

From there, go to your computer manufacture's website and download the latest driver for the internet and install it.

If it still doesn't work from there, let us know.

Report •

December 27, 2011 at 10:45:13
I am unsure about the driver. The site was a bit confusing about that. I will try again later.

Report •

December 28, 2011 at 13:05:33
It looks to me as if NetBios over TCPIP does not work, could that be the culprit?

I don't know why I am told that the Network Adapter is disconnected??

Report •

Related Solutions

December 29, 2011 at 11:02:14
No, that's not the culprit.. even then your internet would work.

If the network adapter is disconnected, that right there is the culprit. Did you get anywhere in trying to figure out what was causing that error?

Report •

December 29, 2011 at 11:45:51
Nope. I have no clue why it says "Network adapter is disconnected"

Report •

Ask Question