Click here for important information about

usb access on Belkin N+ wireliess router

Belkin N+ wireless router
February 21, 2010 at 07:03:25
Specs: Windows Vista, 4GB
I do have the Belkin router, but can't acess the
usb drive. When I put in a drive the blue light
isn't even burning. In contact with Belkin
support I had to upgrade the firmware, so I did
but still nothing. I did everything that was tried
in the previous topic about this matter. But
nothing works.
Does someone still have any good idea. (I did
read the manual, I did install the Belkin
Storage manager).
When I look in the Belkin router software I get:
usb: not connected.
I guess there is something wrong with the

See More: usb access on Belkin N+ wireliess router

February 21, 2010 at 07:29:34
does the usb working in your pc?
have you formatted it and shared it on your pc successfully?

Report •

February 21, 2010 at 08:59:02
yes, the usb devices on my computer are working fine. I can use
all external usb drives directly on my computer.

Report •

April 12, 2010 at 12:59:43
This worked form me:

Windows 7

Click on Start - in the box ‘Search programs and files’ enter \\

(if prompted to enter Username and Password enter Guest in the Username box and leave the Password box empty. Click ok.

This should then create a new File Explorer windows. This should reveal your newly mapped network drive showing a network folder (mine was called ‘sda1’). Right click on this network folder and select ‘Map Network Drive’. Select the drive letter you wish to choose. Tick the box ‘Reconnect at logon’. Click ‘Finish’.

This will then open a new File explorer window showing the newly created connection to your HDD.

(Note if prompted for Username/Password use username 'Guest' and leave the password box empty.)

Hope it works for you - Tony

Report •
Related Solutions

Ask Question