Tp link router no connection thru intrnet port wired/wireles

December 10, 2017 at 12:03:06
Specs: iPad
After an attempt to upgrade firmware on my TL-wr940n I now have no internet connection wireless or wired to my MacBook. No other devices can connect to WiFi. I called tech support and they said it was showing up as faulty cable. But checking the cable connection in different ports proved it to be the internet port itself instead of cable. When we connected to port 1 the connection was at 100% but only connected 10% when put in the internet port. They say it is most likely fried and we will need to replace router. But the router has been randomly flashing from orange to blue showing no connection to having connection... we tried resetting the router and have done basic troubleshooting steps like unplugging and plugging back in securely. I’m hoping someone can offer some advice in how we can fix it ASAP.

See More: Tp link router no connection thru intrnet port wired/wireles

Reply ↓  Report •

#1
December 10, 2017 at 13:14:52
Often overlooked with many a router... the power supply or mains adapter - the external version in this case.

If that's playing up you can get exactly the flashing light situation you have. I have seen the equivalent problem with two non TT-link routers. Replacing the power adapter resolved it.

See if you can borrow a known good power adapter to test the router afresh. Simply checking the voltage out on your present adapter won't likely be good enough. Power adapters may read ok off load (i.e. not conne ted to a device), but once under load the volts drop if the adapter is failing.

If the router was provided by your isp then ask them to send/lend you a new power adapter to test the router afresh.

If you obtained the router from wherever, then you have to find the adapter elsewhere?

Ensure and replacement adapter is the correct volts out (12volts according to TP-link) and can deliver "at least" 1.00amp; a little more is OK - but not less. Also ensure the connector tip is the correct way round re' polarity, and the correct size.

If you look for a specific TP-link replacement adapter then check the reviews of those sold.

Amazon is often a good source for adapters. But don't necessarily buy the cheapest; always (again...) check specs., reviews, and then consider price.

If you buy via Amazon (and in this case if the problem isn't resolved with a new power adapter..) you can usually return items as not needed or similar?

message edited by trvlr


Reply ↓  Report •

#2
December 10, 2017 at 17:32:40
"After an attempt to upgrade firmware on my TL-wr940n..."

Why would you think the problem is anything other than the firmware flash? Are you certain you used the firmware for the correct hardware version?

http://www.tp-link.com/us/download/...


Reply ↓  Report •

#3
December 11, 2017 at 02:17:14
Coincidence is a queer event... Even though the problem arrived post a firmware update... to rule out the power source entirely might not be wise...?

Reply ↓  Report •

Related Solutions

#4
December 11, 2017 at 11:15:52
First of all, thank you for your time, to those who replied.
The reason I mentioned the firmware fail is because I didn’t understand the instructions and was concerned that my mistake might have contributed to this problem considering it’s perfect timing. The tp-link firmware stated for me to unplug some things then later advised against the installation being done wirelessly. So I left the cable plugged in and went on with it.. after I did the restart/reboot I wasn’t able to get internet connection. And have not been able to since. It has now been 2 days no WiFi, no internet, no clue. But 2 days prior (Thurs) we had a power outage due to bad weather and again last night for reason unknown. I don’t know what could of caused it so I assume any and everything. I’m not technically inclined but I do know I just bought this router less than 5 months ago and compared to my last router, which lasted me a few years, it is a disappointment. But before I start blaming the router I want to know if this was my F up and either way just hope that I can find a solution to the problem. Please keep the suggestions coming and thank you in advance!

Reply ↓  Report •

#5
December 11, 2017 at 11:45:27
When you install and configure a router of your own to connect to the internet etc.; rather than using one provide by your isp, you have to login to its hoe page, and then get then enter the login/password for the broadband service in the correct section.

This is how to login to that model router;

http://m.setuprouter.com/router/tp-...

Incidentally in the full manual they offer 192.168.0.1 and not 192.168.1.1 as the router lip address; so you may have to try both in order to gain access.

This is the full manual - a pdf download. Chapter four is the area that covers connecting to your isp - where you enter the login/password your isp provided...

http://static.tp-link.com/191001210...

Routers provided by the isp "usually" come preconfigured to connect automatically to their service; i.e. they have already entered the login (user-name) and password. Why after a firrnware update it doesn't login to the service as before???

Also note the comments in section 1.2.1. re' the LEDs.


Reply ↓  Report •

#6
December 11, 2017 at 11:50:28
Incidentally - as theTP is only five months ode... you could contact vendor and simply say it's not working... Don't feed them information re' what you were doing with regards to firmware upgrades. Simply say that after it was powered down, it wouldn't work again when powered up. That you tried a full reset - but no joy there either. Leave it at that and see if they will honour the warranty and replace (for free)?

Reply ↓  Report •

#7
December 11, 2017 at 13:39:31
I would also return it under warranty.

You have to be a little bit crazy to keep you from going insane.


Reply ↓  Report •

#8
December 11, 2017 at 20:25:39
As I stated before, if everything was fine until you attempted the firmware flash, that is where you should be concentrating your efforts.

Did you try re-flashing the firmware? It's pretty straightforward. You need to know which version of the router you have - apparently there were six of them (v1 thru v6) - & then download the appropriate firmware. It's a .ZIP file so the contents have to be extracted. One of the files in the folder is the instructions. The router should be connected to a computer via an ethernet cable & the cable from the internet provider should be disconnected from the router. Login to the router by going to http://tplinkwifi.net & entering the default username & password (admin/admin). If you created your own name/password, you'll have to login with them instead. Go to System Tools > Firmware Upgrade, click Browse & go to the downloaded folder with the .BIN file, & then click Upgrade. Wait until it completes.


Reply ↓  Report •

Ask Question