Solved tp link model pa211 not showing mains power light

January 17, 2015 at 08:38:25
Specs: Windows 7
both units worked fine for a good period of time, then one failed followed by the remaining unit about two months later, any ideas please.

See More: tp link model pa211 not showing mains power light

Report •

January 17, 2015 at 09:35:35
✔ Best Answer
Sadly these items can and do fail... I have a set of Devolo lan adapters (85Mbps) and over a five year period or so, one has failed. It doesn't light up...

Sometimes there is a fuse inside which you "may" be to access and test; replacing if blown... Otherwise I suspect your modules have died...?

This is the "idiot's guide" (the manual) for your kit:

In it they refer to a fuse - 2.5amp but refrain from saying where it is; nor how to access it. Not having one in front of me I'm surmising there will a few small philips screws to remove to access the inside of the module; and thus the fuse?

This link has an interesting discussion re' these modules; worth a serious browse at least. Appears they have a 3yr warranty too?

And this Youtube video may of interest too:

Be aware though that going inside may void any remaining warranty aspects; so perhaps first contact TP link re' warranty replacements (if still under warranty)?

Report •
Related Solutions

Ask Question