The unsolveable connection problem

July 11, 2009 at 16:44:51
Specs: Windows Vista
This problem has defied all attempts by some half-dozen people, including multiple trained tech support guys (from the States, not foreigners). I've spent some time looking through forums and Google, no luck. I hope somebody here can help!

The Situation:
Wireless router. Multiple computers on the network, some desktop and some laptop, plus a cell phone and PSP. Only one desktop doesn't work. Computers are using Vista and XP, problem computer is using Vista.

The Specs:
HP desktop purchased at Best Buy just over a year ago. Full memory upgrade, 400+ GB hard drive, the works. Zonet Wireless 8185 card is the only addition to the stock model.
Windows Vista 32 bit. Fully updated as of a few months ago.
NO Anti-Virus, firewall, or other similar programs installed.

Shows full connection to wireless network, full bars. Unable to access anything through browsers (IExplorer or Firefox). Unable to ping outside address (like

What we've tried:
Computer connected to internet in Idaho, family moved to South Dakota and got a new internet provider. The other computers switched over just fine, this one wouldn't connect at all.

Tinkered around with settings, found TCP/IP 4 wasn't activated. Clicked it on, double checked other settings to find them correct. Renewed IP addresses, got one, but it was a 169. However, the computer finally recognized the network as existing. Connected with limited access only.

Checked password for accuracy, reset router settings from computer. Reset router by unplugging power, waiting, plugging in. Renewed IP address. Disabled Windows firewall. Used three different drivers for Zonet card. Computer still only connected with limited access only.

Called tech support (the internet provider; HP won't provide support because it's out of warranty by 3 months). They verified our password as correct, verified that there were no problems on their end. Verified that the account was set up for 10 simultaneous connections, removing the possibility of us overloading the account with the six other devices accessing it.

Tech guy disabled router firewall. Used netsh commands to reset IPs and all that jazz. We verified other settings for accuracy. Tried to ping from cmd and got nothing.

Restarted in Safe Mode with network access. Same results; Windows says it's connected, but no packets are received, can't ping out, nothing can get through.

Attempted to force manual IP and DNS selections. Using IP provided by tech guy, entering into Network status -> TCP/IPv6 -> Properties -> Manual selection, we got the error that it was an "invalid address". What?

After the few hours with tech support, it said we were fully connected, but still couldn't get anything through. Ended tech support call. Uninstalled network card, swapped with totally different card. Installed, same results: "full connection" without any actual access. Reinstalled original card, sat down and cried.

Okay, didn't really cry. But yeah. We tried every suggestion through Windows "diagnose" pop-ups. Looked online for help, found some stuff on MAC addresses, tried that and locked down the whole network. Had to call tech support again, had them reset router settings to undo my mistake. Asked this tech support guy for suggestions, swapped ideas, ended up with the same stuff the first guy had thought up.

It seriously seems like something is blocking the connection, like a mystery firewall somewhere. But there isn't an anti-virus installed, nor another firewall, and nothing else should load up in safe mode...

So, does anyone have any ideas? None are too simple, none are too complicated. I want to hear them all.

See More: The unsolveable connection problem

Report •

July 11, 2009 at 17:22:24
Could be the default network stacks are corrupt. Try using the "system file checker" to repair the system files. haven't used it in a long time, so confirm this first, but I believe you just have to use "sfc /scannow" at the command line.

Does a wired connection work?

-Ryan Adams
Free Computer Tips and more:

Paid Tech Support: Black Diamond

Report •

July 11, 2009 at 20:30:38
Hey, now there's a new suggestion. I'll definitely follow up on that next time I'm over there.

The router is upstairs, the computer in question downstairs; a wired network would be a pain to set up. Drilling holes in rental houses just doesn't go over well. However, there is a computer in the same room which IS working off the wireless; I did try to piggy-back off its connection via cable. I didn't include it in the above explanation because I'd like to avoid doing it; as far as I know, you would need both computers on for the Vista machine to be online, the cable would still be a hassle, etc.

Unfortunately, I couldn't get the two computers to play nice (one is Vista, the other, XP). I didn't spend much time with it though; after six hours on the project it was time for a break. If I can't get the wireless working, I will spend more time and figure out the wired setup. Better than nothing!

Any other ideas? I won't be able to test RTAdams' sfc idea for a few days; best to go in with as many ideas as possible.

Report •

July 12, 2009 at 04:10:50
Have you tried bringing the computer upstairs? The signal is very weak above and below the router. The 169 address means the computer could not find a valid address.

Report •

Related Solutions

July 12, 2009 at 06:33:26
This problem has defied all attempts by some half-dozen people, including multiple trained tech support guys

A "helpdesk" person is trained to read their question/answer database. They're not a trained "technician". Which is why, whenever I'm forced to call any support line, I always ask for their second level support. That normally gets you in touch with an actual trained, skilled, technician who may even have experience on the equipment you're having trouble with.

problem computer is using Vista.

That would be the biggest problem right there. I'd bet cash money you could install XP and it would work just fine.

The router is upstairs, the computer in question downstairs; a wired network would be a pain to set up. Drilling holes in rental houses just doesn't go over well.

If you have a long enough cable, or can get one, do so and try it wired and see if that doesn't work. Nobody said it had to be permanent, at this stage we're troubleshooting and that should be the next step you take. If you have a problem getting a long enough cable, carry the computer to the router and plug it in there and test and let us know if it works when wired.

Since you're trying to use wireless and getting an APIPA address (the 169 address you get when your computer can't contact a DHCP server) my first thought is the wireless interface. Either it, or the drivers are having issues. I would try updating the NIC drivers with newer ones if possible.

If the working computer in the same room as the problem computer has a wireless NIC you can actually remove (ie: not part of the motherboard) you could also try putting that NIC, which you know works, into the problem PC (either removing or disabling the wireless NIC presently in there ) and see if that doesn't work.

Give those a try and let us know what happens.

Report •

July 12, 2009 at 06:41:03
Instead of moving the computer upstairs, just unplug the router, and move it down stairs. All you need is the router powered up and an Ethernet cable between the router's "LAN" port and the computer. This will let us see if the computer can get an IP address when using the wired interface. If you still get a 169 IP address this way, then it is not the wireless adapter or it's drivers, but rather the underlying network components of Windows. The SFC method I mentioned above will hopefully fix that.

Also, I know you don't currently have any firewall software installed, but have you ever? I've had two clients in the last month that had just removed Symantec Internet Security, and were having firewall issues. Even though the software had been "uninstalled" it was still blocking network traffic. Symantec makes a stand alone download available on there site to more thoroughly remove the software, and running that fixed the issue both times.

@Curt: I too am sure if he installed XP it would work. But I'm also pretty sure that reinstalling Vista would make it work. This isn't some common Vista bug/quirk.

-Ryan Adams
Free Computer Tips and more:

Paid Tech Support: Black Diamond

Report •

July 12, 2009 at 07:26:45
First, I should make it clear that this isn't my computer. It isn't my decision to change the OS. Also, I don't have access to a Vista disk; the computer in question didn't come with one, or even a recovery disk. (Insert offensive comment about HP here)

There is no problem with signal strength; the computer shows full bars, the other computer in the room shows full bars and works, and my laptop which I brought over, and was using a foot away from the tower, showed full bars and worked fine.

The drivers we tried included the one she had installed, the default Windows one, and the most updated one I could find online. That should rule out drivers.

Coincidentally, the NIC card I swapped it out with was the one in the working computer right next to it.

I will have to ask if the owner has had firewalls installed and later removed; a good thing to follow up on.

I can't move the router downstairs; it's cable internet, and no cable connection is downstairs. I could move the computer upstairs. Obviously not a permanent solution, but good for fact-finding and eliminating possibilities. I will try this.

Thanks for the suggestions guys! Keep 'em coming, I will try this stuff when I can get back over there.

Report •

July 12, 2009 at 10:45:02
It doesn't matter how many drivers/cards you try, if the Windows TCP/I Pstack is messed up, nothing will work. This article details one way to reset the TCP/IP stack but using the System File Checker as discussed earlier might be better.

Also, you can move the router, as you don't need an internet connection to test if the wired connection would work. Just take the router and its power cord down to the computer, and then plug the computer into the router with an Ethernet cable. Obviously you won't be able to access the Internet, but you will be able to see if the computer is getting a valid IP from the router.

-Ryan Adams
Free Computer Tips and more:

Paid Tech Support: Black Diamond

Report •

July 12, 2009 at 14:07:11
Ah, didn't know you could get a valid IP without a valid connection... in that case, I will do that. Much easier than moving the whole computer. Also, thanks for the link; I'll probably try the first method, then the second if the first doesn't fix it.

Report •

July 12, 2009 at 15:08:13
I would move the router first. This is easy, and will tell us if it is related to the wireless or the computer's TCP/IP settings. Again, just put the router next to the problem computer, give it power, then connect the computer to one of the routers "LAN" ports with an ethernet cable. Restart the computer for good measure, then open a command prompt and do "ipconfig". let us know what IP address it shows for the wired interface.

If it starts with anything other than "192.168" then the problem is still there and the issue is not with the wireless adapter or drivers. At this point, you can try resetting the TCP/IP as detailed in the link above.

Should that fail to work, try using the SFC as detailed here:

Should that also fail, try setting the IP (version 4, not the IPv6) settings manually on the computer. Use "ipconfig" on another working computer on the network to get all of the values you'll need, but I would guess the IP address will be in the range, the gateway will be, and the subnet mask will be These values could be different though, so check a working computer on the network to find out.

-Ryan Adams
Free Computer Tips and more:

Paid Tech Support: Black Diamond

Report •

July 13, 2009 at 05:50:53
the computer in question didn't come with one, or even a recovery disk. (Insert offensive comment about HP here)

Likely there's a "recovery partition" on the hard drive. Most manufacturers started doing this some years back. It's a wonderful idea until the hard drive craps out and they, in their infinite wisdom, ship a blank drive as a replacement forcing you to order a disk..........yes, the voice of bitter experience

With XP, if I suspected corrupt files in the TCP/IP stack, I would uninstall it, reboot, then reinstall it. You might want to try that on vista.

Report •

July 16, 2009 at 12:02:23
Sweet, lots of suggestions. I'm getting the sense that there won't be many more until I can rule out some possibilities (or, *GASP*, get it working!), though if anybody does come up with something... well, you know.

In any case, I'm out of town until the 23rd or so. Around then is when I'll put all your advice to good use and then post the results. Thanks!

Report •

August 17, 2009 at 09:12:04
MAC address filtering?

ʇxǝʇ uʍop ǝpısdn

Report •

Ask Question