Specified Network Name is No Longer Available

Hewlett-packard / Cq5300y
November 13, 2017 at 18:12:44
Specs: Windows 7 Professional (SP1) 64-bit, AMD Athlon II X2 215, 4 GB
Hi, folks -

I have a home network set up with three computers, all connected via ethernet to the home router - one MacBook Pro (mid-2014 retina 15" running OS High Sierra 10.13.1), and two Windows PCs.

One of the PCs is running Windows 7 Professional (SP1), and the other was running Windows 7 Home Premium. Everything is connected to the same workgroup. File sharing is turned on for all machines.

The Windows 7 Professional machine is able to see, read & write to the shared folders on Mac.
The Mac is able to see, read & write to the shared folders on both PCs.
The Windows 7 Home Premium machine was able to see, read & write to the shared folders on the Windows 7 Professional PC.
The Windows 7 Home Premium machine was able to see the Mac, but was unable to connect to it. Instead, it kept displaying the error message:

"The specified network name is no longer available."

After days and days of google searches, I learned it could be a flaw in Windows 7 Home Premium. So, I upgraded that machine to Windows 7 Professional.

However, I am still receiving the same error message.

I also found, through search, that the error message is often related to SMB issues and/or a failed network adapter. I don't believe it's the latter, because the computer can connect to the other Windows 7 Professional just fine, and the other computers can connect to it.

Does anyone know what the problem might be or what settings I should check?

Thanks in advance!
Susan


See More: Specified Network Name is No Longer Available

Reply ↓  Report •

#1
November 14, 2017 at 02:10:54
This article could solve your problem:
https://www.tweaking4all.com/os-tip...

Reply ↓  Report •

#2
November 14, 2017 at 10:43:38
Thanks for the link, Sluc.

I'm not so sure SMB on the Mac is the problem, however, The other Windows 7 Professional PC on the network has no trouble whatsoever connecting to the Mac.

It must be something... some setting or such... on this particular Windows 7 Professional PC. I just have no idea what to check. Turning off its firewall made no difference.


Reply ↓  Report •

#3
November 15, 2017 at 20:45:02
Probably a silly question after all you've done but can I assume you have tried turning the router off for about half a minute? It's just that I've known this fix similar problems.

Always pop back and let us know the outcome - thanks


Reply ↓  Report •

Related Solutions

#4
November 16, 2017 at 16:30:49
Thanks for the suggestion, Derek. I DID try rebooting the router. It didn't make a difference.

Another strange thing is... before trying to connect from the problem-child PC to the shared folders on the Mac, I always connect to the PC's shared folders from the Mac. (I read on another forum that this can sometimes help.) Unfortunately, in my case, it doesn't.

When I go to the Network & Sharing Center on the problem-child PC and click on "See full map," the Mac appears at the bottom of the screen under where it says, "The following discovered device cannot be placed in the map." It doesn't give me a reason why, however, and I haven't been able to find any possible solutions via Google search.


Reply ↓  Report •

#5
November 16, 2017 at 16:38:10
I've heard of a case where the SMB server on a Mac just decides it doesn't like some non-Apple device, and stops talking to it. I've never heard of a fix, but maybe try restarting the SMB service on the Mac?

How To Ask Questions The Smart Way


Reply ↓  Report •

#6
November 16, 2017 at 17:09:33
Hi, Razor2.3

Unfortunately, restarting the SMB service on the Mac didn't make a difference.

This whole thing is so crazy. It's like there's a ghost in the PC or something.


Reply ↓  Report •

#7
November 17, 2017 at 16:59:47
Any difference in network settings on both PC's?? Network defined as Home or Work network?
Does the MAC need to authenticate PC users? Does it allow the user from the "troubled" PC?


Reply ↓  Report •

#8
November 17, 2017 at 18:58:01
Other than making sure all the computers are on the same home network, which they are, I'm not sure what other network settings to check.

The Mac is able to access the "problem" PC's shared folder just fine. Even when I connect to the "problem" PC from the Mac first, I still can't get the "problem" PC to connect back to the Mac.


Reply ↓  Report •

Ask Question