Slow transfer rate/slow loading

March 20, 2009 at 10:53:05
Specs: Windows XP, P4, 2.8Ghz/640MB
Hello everyone!

I could really use your help as I am almost about to give it all up and toss my computers throughout the window along with the router.
I have this problem with extremely slow transfer rate when downloading files (from any server) and several websites are loading really slow.

I'm connected using ADSL at 2.5Mbps. I have 2 PCs in my home network. Both my computers have Windows XP SP3 installed and are connected using Ethernet cables (RJ-45). I'm using the Siemens SL2-141 router.

Up until a week ago everything was going just fine. I was able to download files quickly and the transfer rate was about 225KB to 300KB (also in P2P software).
Now, every file I download is about 40KB or in much worst cases 12KB.

In my country, there are only 2 infrastructure companies available: One works via ADSL and the other through cables.
I got connected with the internal server of my infrastructure and did a speed test. The result was excellent - downloaded a file at 300KB.
Realizing there's nothing wrong with my infrastructure, I called up my ISP and after several checks, nothing was wrong on their end.
The ISP tried to connect with my username and password and said the speed is as it should be (on their end, of course).

I scanned both my computers for viruses and found a Trojan, but I think I got it removed.
I really don't know what I should do next.... I mean, if I can download at full speed when connected to the infrastructure, how come I can't download at full speed when I'm connected to my ISP? I turned off and unplugged one of the PCs just to make sure there's no use of any bandwidth. I also closed any process and application. I've tried ping and got some packet loss. Also used Netstat to see online connections - nothing was suspicious. I've tried NETSH on one computer and even that didn't help. Tried hard-reset to the router and still...

I'm considering formatting the computer, but I don't think that would work... I mean, the problem exists on both computers... Both of them are experiencing slow transfer rate.

Any advice??

Thanks,
David.

"I'm tired. But then again I'm so hungry I can't sleep. But what's the point of eating if your sleepy?" - Sniff, The Moomins.


See More: Slow transfer rate/slow loading

Report •


#1
March 20, 2009 at 11:05:54
Download, update and run anti malware from malwarebytes.org

Then download and run TCPOptimizer.exe from speedguide.net Make the recommended changes.

If there is still a problem run Hijack This and post the log.


Report •

#2
March 20, 2009 at 12:34:39
Hi,

thanks a lot for the reply.

I've ran the anti-malware software. It detected and removed 5 malwares (3 registery entries and 2 files). I've also downloaded TCP optimizer but the problem presists.

Here's the Hijack This log:
Logfile of Trend Micro HijackThis v2.0.2
Scan saved at 21:25:03, on 20/3/2009
Platform: Windows XP SP3 (WinNT 5.01.2600)
MSIE: Internet Explorer v8.00 (8.00.6001.18702)
Boot mode: Normal

Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\system32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe
C:\Program Files\Alwil Software\Avast4\ashServ.exe
C:\WINDOWS\system32\spoolsv.exe
C:\Program Files\Bonjour\mDNSResponder.exe
C:\WINDOWS\system32\svchost.exe
C:\Program Files\Java\jre6\bin\jqs.exe
C:\Program Files\Common Files\Microsoft Shared\VS7DEBUG\MDM.EXE
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\system32\svchost.exe
C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe
C:\Program Files\Alwil Software\Avast4\ashWebSv.exe
C:\WINDOWS\Explorer.EXE
C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe
C:\WINDOWS\BricoPacks\Vista Inspirat 2\RocketDock\RocketDock.exe
C:\WINDOWS\system32\ctfmon.exe
C:\Program Files\Google\GoogleToolbarNotifier\1.2.1128.5462\GoogleToolbarNotifier.exe
C:\Program Files\HP\Digital Imaging\bin\hpqtra08.exe
C:\Program Files\HP\Digital Imaging\bin\hpqSTE08.exe
C:\Program Files\FlashGet\flashget.exe
C:\WINDOWS\system32\mspaint.exe
C:\Program Files\Lavasoft\Ad-Aware\Ad-AwareAdmin.exe
C:\Program Files\Lavasoft\Ad-Aware\Ad-AwareAdmin.exe
C:\Program Files\Internet Explorer\iexplore.exe
C:\Program Files\Internet Explorer\iexplore.exe
C:\Documents and Settings\Tiram\Desktop\TCPOptimizer.exe
C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.yahoo.com/
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = about:blank
R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyOverride = *.local
O2 - BHO: Adobe PDF Link Helper - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll
O2 - BHO: flashget urlcatch - {2F364306-AA45-47B5-9F9D-39A8B94E7EF7} - C:\Program Files\FlashGet\jccatch.dll
O2 - BHO: Java(tm) Plug-In SSV Helper - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre6\bin\ssv.dll
O2 - BHO: Google Toolbar Helper - {AA58ED58-01DD-4d91-8333-CF10577473F7} - C:\Program Files\Google\Google Toolbar\GoogleToolbar.dll
O2 - BHO: Google Toolbar Notifier BHO - {AF69DE43-7D58-4638-B6FA-CE66B5AD205D} - C:\Program Files\Google\GoogleToolbarNotifier\5.0.926.3450\swg.dll
O2 - BHO: Google Dictionary Compression sdch - {C84D72FE-E17D-4195-BB24-76C02E2E7C4E} - C:\Program Files\Google\Google Toolbar\Component\fastsearch_219B3E1547538286.dll
O2 - BHO: Java(tm) Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} - C:\Program Files\Java\jre6\bin\jp2ssv.dll
O2 - BHO: JQSIEStartDetectorImpl - {E7E6F031-17CE-4C07-BC86-EABFE594F69C} - C:\Program Files\Java\jre6\lib\deploy\jqs\ie\jqs_plugin.dll
O3 - Toolbar: &Google Toolbar - {2318C2B1-4965-11d4-9B18-009027A5CD4F} - C:\Program Files\Google\Google Toolbar\GoogleToolbar.dll
O4 - HKLM\..\Run: [avast!] C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe
O4 - HKLM\..\Run: [Ad-Watch] C:\Program Files\Lavasoft\Ad-Aware\AAWTray.exe
O4 - HKLM\..\RunOnce: [Malwarebytes' Anti-Malware] C:\Program Files\Malwarebytes' Anti-Malware\mbamgui.exe /install /silent
O4 - HKCU\..\Run: [RocketDock] "C:\WINDOWS\BricoPacks\Vista Inspirat 2\RocketDock\RocketDock.exe"
O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe
O4 - HKCU\..\Run: [swg] C:\Program Files\Google\GoogleToolbarNotifier\GoogleToolbarNotifier.exe
O4 - HKUS\S-1-5-19\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\CTFMON.EXE (User 'LOCAL SERVICE')
O4 - HKUS\S-1-5-20\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\CTFMON.EXE (User 'NETWORK SERVICE')
O4 - HKUS\S-1-5-18\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\CTFMON.EXE (User 'SYSTEM')
O4 - HKUS\.DEFAULT\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\CTFMON.EXE (User 'Default user')
O4 - Global Startup: HP Digital Imaging Monitor.lnk = C:\Program Files\HP\Digital Imaging\bin\hpqtra08.exe
O8 - Extra context menu item: &Download All with FlashGet - C:\Program Files\FlashGet\jc_all.htm
O8 - Extra context menu item: &Download with FlashGet - C:\Program Files\FlashGet\jc_link.htm
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\OFFICE11\REFIEBAR.DLL
O9 - Extra button: FlashGet - {D6E814A0-E0C5-11d4-8D29-0050BA6940E3} - C:\Program Files\FlashGet\FlashGet.exe
O9 - Extra 'Tools' menuitem: FlashGet - {D6E814A0-E0C5-11d4-8D29-0050BA6940E3} - C:\Program Files\FlashGet\FlashGet.exe
O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
O16 - DPF: {195B4BBF-E1E4-4020-9773-0A8C6F65EA35} (CPlayFirstCookingDasControl Object) - http://www.shockwave.com/content/co...
O16 - DPF: {20A60F0D-9AFA-4515-A0FD-83BD84642501} (Checkers Class) - http://messenger.zone.msn.com/binar...
O16 - DPF: {6E32070A-766D-4EE6-879C-DC1FA91D2FC3} (MUWebControl Class) - http://www.update.microsoft.com/mic...
O16 - DPF: {C3F79A2B-B9B4-4A66-B012-3EE46475B072} (MessengerStatsClient Class) - http://messenger.zone.msn.com/binar...
O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://fpdownload2.macromedia.com/g...
O23 - Service: avast! iAVS4 Control Service (aswUpdSv) - ALWIL Software - C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe
O23 - Service: avast! Antivirus - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashServ.exe
O23 - Service: avast! Mail Scanner - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe
O23 - Service: avast! Web Scanner - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashWebSv.exe
O23 - Service: ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762## (Bonjour Service) - Apple Computer, Inc. - C:\Program Files\Bonjour\mDNSResponder.exe
O23 - Service: FLEXnet Licensing Service - Macrovision Europe Ltd. - C:\Program Files\Common Files\Macrovision Shared\FLEXnet Publisher\FNPLicensingService.exe
O23 - Service: Google Updater Service (gusvc) - Google - C:\Program Files\Google\Common\Google Updater\GoogleUpdaterService.exe
O23 - Service: Java Quick Starter (JavaQuickStarterService) - Sun Microsystems, Inc. - C:\Program Files\Java\jre6\bin\jqs.exe
O23 - Service: Lavasoft Ad-Aware Service - Lavasoft - C:\Program Files\Lavasoft\Ad-Aware\AAWService.exe

--
End of file - 6894 bytes


Thanks again!

"I'm tired. But then again I'm so hungry I can't sleep. But what's the point of eating if your sleepy?" - Sniff, The Moomins.


Report •

#3
March 20, 2009 at 14:47:34
I'm not sure why all those cab files are needed for those web sites. It's up to you if you think they are necessary. I uninstall Google Toolbar too, at least temporarily.

O16 - DPF: {195B4BBF-E1E4-4020-9773-0A8C6F65EA35} (CPlayFirstCookingDasControl Object) - http://www.shockwave.com/content/co...
O16 - DPF: {20A60F0D-9AFA-4515-A0FD-83BD84642501} (Checkers Class) - http://messenger.zone.msn.com/binar...
O16 - DPF: {6E32070A-766D-4EE6-879C-DC1FA91D2FC3} (MUWebControl Class) - http://www.update.microsoft.com/mic...
O16 - DPF: {C3F79A2B-B9B4-4A66-B012-3EE46475B072} (MessengerStatsClient Class) - http://messenger.zone.msn.com/binar...
O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://fpdownload2.macromedia.com/g...


Report •

Related Solutions

#4
March 21, 2009 at 01:37:09
Hey again,

Hmm... how odd... I went to sleep and I just checked the download rate and it's back to normal (250KB-300KB) at all servers and pages are loading quickly. I'm positive it's the anti-malware scan we performed.

Still, I'm not taking any chances, so I'll format the compter as well.

Thank you for all your help!!! :-)

"I'm tired. But then again I'm so hungry I can't sleep. But what's the point of eating if your sleepy?" - Sniff, The Moomins.


Report •

#5
March 21, 2009 at 04:11:34
I spoke too soon!

The problem still presists...
I'm positive there's nothing wrong with my computers...
Maybe the cables are messed up?

If changing the cables won't work... I'm going to have a little chat with my ISP... This is so frustrating!

"I'm tired. But then again I'm so hungry I can't sleep. But what's the point of eating if your sleepy?" - Sniff, The Moomins.


Report •

#6
March 21, 2009 at 04:47:09
Changing cables won't make a difference at 2.5 Mbps. Your patch cable is either working or it's not working at all.

Up until a week ago everything was going just fine. I was able to download files quickly and the transfer rate was about 225KB to 300KB (also in P2P software). Now, every file I download is about 40KB or in much worst cases 12KB.

Maybe your provider is choking your connection due to bandwidth usage. A lot of them nowadays look for bandwidth hogs using p2p software (that transfer illegal files) and limit them.

Since you've ruled everything else out, you might want to try calling your provider about this issue. Chances are they may be able to help you.


Report •

#7
March 21, 2009 at 05:57:57
Formatting isn't the way to go since the problem is on 2 PCs. Delete those cab files.

Report •

#8
March 21, 2009 at 07:04:19
Thanks for the replies...

I just formatted one of my computers (not the one where the spyware was detected). I installed a fresh copy of Windows Vista Ultimate integrated with SP1. I got it connected only to the router and the transfer rate was and still is low.
That is, as you say, defently ruling out any possible cause there's something wrong with my computer(s) and/or router, cables.

You know what's the irony of it?
I just recently got accepted to a job, as a technical support for my ISP. I'm going to show them tomorrow...!

I'll also delete those cabs files on my computer and will keep you posted.

Thanks again.

"I'm tired. But then again I'm so hungry I can't sleep. But what's the point of eating if your sleepy?" - Sniff, The Moomins.


Report •

#9
March 21, 2009 at 16:31:25
Good luck on your new job.

Report •

#10
March 23, 2009 at 03:53:42
Hey again,

Well... The problem has finally come to an end.
It was on the ISP's end.

Now the transfer rate is around 300KB/s.
I've added an image of the download window.

Thank you for all your help.
I believe you're doing a great job. Please keep it up :-)

Download status window:
http://img7.imageshack.us/img7/6689...

Thanks again!!!

"I'm tired. But then again I'm so hungry I can't sleep. But what's the point of eating if your sleepy?" - Sniff, The Moomins.


Report •


Ask Question