Shared Folder on Domain

Microsoft Windows server 2003 r2 standar...
October 28, 2009 at 10:35:25
Specs: Windows server 2003
I have one server which is an Active Directory controller with all my users and OU's. Another server which is also a part of the domain has the data files I want to share. However, when I go to set sharing permissions on the separate server with the data I cannot see the users or OU's on my ADir controller. Any ideas of why this can be? Sharing a folder cannot be this hard!

Thanks in advance

See More: Shared Folder on Domain

Report •

October 28, 2009 at 10:46:57
It sounds like you may not have joined that server to the AD domain properly.

Can you see the server in AD?

If you can't, one thing to check quickly is the TCP/IP settings on that server. It's DNS IP must be that of your DC.

Report •

October 28, 2009 at 11:00:36
On the DC I can see my server listed in the "computers" OU. I have changed my DNS IP to that of the ADC controller. I do have a netgear router set to not give out DHCP addresses. I wonder if the netgear router is conflicting with the DNS.

Report •

October 28, 2009 at 12:55:29
The router shouldn't be. If your DC is behind it (ie: downstream) as it should be, then you would forward DNS on the DC and you could either:

A) forward to your router's IP (which in turn forwards to your ISP)


B) forward to your ISP's DNS addresses directly (my preferred method in a case like this)

Not being able to bring up domain users on the share you wish to set access on usually means a problem with the AD and DNS with regard to the problem server.

If it were me, I'd unjoin the server (the right way) from your AD and then I'd join it again and see if that doesn't fix the issue.

You may also want to check the DNS host records and make sure they point at the correct IP for this server. If the host record for the server doesn't have the correct IP, that will cause a problem too.

You do have a statically assigned IP on the server..........right?

Report •

Related Solutions

October 28, 2009 at 13:05:25
Yes, all my servers have static IP's. My comcast ISP is giving a dynamic WAN address. If I wanted a static I'd have to pay for business class. I will try to forward my dns to my routers IP on the DNS server. When you say forward DNS do you mean enter the IP in the forward zone?

Report •

October 28, 2009 at 13:47:29
You put the isps dns server ips in the forwarders tab not the forward lookup zone. Workstations point to your dns server. Any name like the workstation want to resolve goes to the ms dns server which in turn [due to those entries] forwards the request to the isps dns servers.

Report •

October 28, 2009 at 13:52:23
Thank you so much I will experiment, greatly appreciated

Report •

October 28, 2009 at 14:39:55
Yes, all my servers have static IP's. My comcast ISP is giving a dynamic WAN address. If I wanted a static I'd have to pay for business class

I meant you assign your server a static IP within whatever subnet you're using internally............not a static IP from your ISP for your service.

Report •

October 30, 2009 at 11:20:52
Unjoining and rejoining the domain worked like a charm. Although the DNS info will be helpful in the near future. My next task is setting up exchange server 2003! That will be fun...argghhh

Report •

October 30, 2009 at 12:07:38
I feel your pain!

Good luck and thanks for getting back to us and letting us know what worked.

Report •

Ask Question