Seagate 1 TB HD not visible from Belkin

Belkin N+ wireless router
June 18, 2011 at 17:51:06
Specs: Windows 7
Seagate 1 TB HD connected via USB to Belkin double N + wireless router not visible to wireless connected laptop and other devices.

I upgraded to latest Belkin firmware.
NB The wireless router works for providine common internet access for 4 separate devices on homenetwork
NB The wireless router never appears under 'network' in Win 7 file manager.
NB I have been unable to get the Belkin storage manager to work at all under Win 7.
Have connected External drive to laptop to set to 'share' and rename to something short ("Storage")
I reconnected it to wireless router -
I then tried to connect (and map) to \\192,168.2.1\Storage - fail.
At this point Win 7 prompts for a network pwd and informs me I must 'enter a pwd to connect to 192.168.etc.' It says the account to use to logon on to the router is laptop/Admin. Which makes no sense. id expect it to list a router account, not the connecting laptop one. There is no option to change the domain. I've tried every combination of account and pwd, but to no avail.

Pulling my hair out over this one. Ought to have been a simple operation.

See More: Seagate 1 TB HD not visible from Belkin

Report •

June 18, 2011 at 18:15:33
From a similar post:
Might want to review your manual here
Look at section 4 page 20 concerning the storage manager
end quote

Report •
Related Solutions

Ask Question