Router blocking all http??

November 5, 2009 at 09:04:26
Specs: Windows XP
Gnet IP204G router -> Satellite modem. Gnet (Gentek) seems to be out of the modem business so no hope of support.

The system is cycled on/off at least once daily. Four PC's (one wired, three wireless) are all running Win XP Pro.

Out of the blue I lose access to all http sources with any browser using any computer on the network. Email: OK. FTP: OK. https: OK(!) Ping to a given http address --- OK!!

If I go around the router and make a direct connection from any PC to the sat modem - all's well.

Router was hard reset to factory defaults and reconfigured. No difference.

So... probably time for a new router - but this seems like such an unlikely failure mode (waaay too specific). Could I be missing something else?

See More: Router blocking all http??

Report •

November 5, 2009 at 09:10:53
most routers have a test button inside the gui that goes out to the manufacturers web page. Can you test from the router?

all pcs work with direct modem access?

Report •

November 5, 2009 at 09:37:20
Thanks for the thoughts.

Only test utility from within config pages is ping... but I already know that I can ping from the PC so I won't learn anything from that.

And yes, any PC directly connected to the modem is fine.

I'm out in the boonies. Can't borrow anything for a quick test and it'll take a week to ship in another router. Worst-case scenario would be that a new router doesn't help...

Report •

November 5, 2009 at 09:46:12
what are the ping times to say from the router?

Report •

Related Solutions

November 5, 2009 at 09:58:03
From the PC (no router) I get around 650 to 1000. (Remember this is satellite.) I'll have to reconnect the router to try it, then reconnect without it to report back. <sigh> Will be interesting to compare tho.

Report •

November 5, 2009 at 10:10:05
With the router in play, the first test times were about 100ms longer, but I ran a second set after a minute or two and averaged 620ms - better than the first test without the router.

Report •

November 5, 2009 at 10:15:45
Now from a pc with the router connected do a tracert to and post the results for review. Thx

Report •

November 5, 2009 at 11:22:58
I should've mentioned at the start the the error I get, while trying to pull up an http page in the browser is "connection reset while page was loading".

Here's the result of a tracert to yahoo:

Tracing route to []

over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms

2 589 ms 1000 ms 653 ms

3 655 ms 662 ms 705 ms

4 674 ms 657 ms 667 ms

5 677 ms 679 ms 633 ms

6 634 ms 676 ms 680 ms []

7 674 ms 649 ms 677 ms []

8 701 ms 657 ms 661 ms

9 660 ms 682 ms 665 ms []

10 696 ms 642 ms 682 ms []

11 709 ms 686 ms 755 ms []

12 790 ms 770 ms 779 ms []

13 771 ms 672 ms 780 ms []

14 750 ms 761 ms 782 ms []

15 737 ms 681 ms 761 ms []

Trace complete.

Report •

November 5, 2009 at 13:06:41
589 ms 1000 ms 653 ms

I am going to assume is your Satellite modem.

Can you replace the cable between the router and the modem? That is way too long for a modem reply.
Pc direct to the modem has less time?

Report •

November 5, 2009 at 14:18:48
I've already tried replacing the cable a while ago.

Initial response w/o router is comparable.

Report •

November 5, 2009 at 14:22:48
See if you can telnet a web page port 80. If all other common services are OK then it is a port 80 issue. As to why I can't say.

Guess you could try a live cd like knoppix 5.1 just to be sure it isn't the OS.

Playing to the angels
Les Paul (1915-2009)

Report •

November 5, 2009 at 15:25:17
Thanks for the suggestions.

I've never used telnet, but I'm game to try. Funny you should mention a live CD, as I just ordered a couple of Linux distributions the other day. But as for the OS, I refer you to the top of the thread. I have the same behavior on 4 machines -- any one of which works fine connected directly to the modem -- so it seems unlikely to be the OS.

The only thing in this picture that doesn't work is the router, which has been fine for years. While I think it would be awfully weird to have a hardware failure be this specific in its effect, I'm out of guesses.

Thanks again

Report •

November 5, 2009 at 15:28:02
Same ms rating to the modem with or without the router points not to the router but to the modem as the problem.

Report •

November 5, 2009 at 16:44:04

Forgive me if this is a naive question, but then why is everything fine (or at least functional) when any PC is directly connected to the modem?

I've been doing some searching on related topics. There is an example of a trace (mtr, but whatever) from a satellite customer at

You can see that the first hop from the router in the example shown is ~670ms. Seems like that first IP address is not the modem, but rather, it is the earth station to which the modem is yakking via satellite. I ain't sayin' I know this, I'm just sayin' it looks like this. :-)


Tried telnet and was able to d/l a page off my employer's website while directly connected to the modem. With the router, no dice.

Thanks dudes, this is more of a help than you might think.

Report •

November 5, 2009 at 18:53:33
Log on to the router and view web based config. Seems to be the router blocking port 80

Playing to the angels
Les Paul (1915-2009)

Report •

November 6, 2009 at 05:43:16

I agree, and that's where I went as soon as I narrowed this issue down to the router. But there are no filtering rules of any kind in effect, and early on in this process I did a hardware reset to factory defaults to make dead sure. Exact same symptoms. I've even created various filtering rules and then cleared them again hoping to free a stuck bit somewhere. (Desperate.)

About the only thing left to do is try a different power supply on the router. I've seen power supply issues create some pretty exotic problems... although at the risk (nay, guarantee) of repeating myself, this is an oddly specific fault and highly unlikely to be attributable to power, so I don't hold out a lot of hope.


Report •

November 6, 2009 at 06:22:55
looking in the router what is the wan ip address?

1 <1 ms <1 ms <1 ms Your router

2 589 ms 1000 ms 653 ms their equipment - modem

3 655 ms 662 ms 705 ms their equipment

4 674 ms 657 ms 667 ms their equipment

5 677 ms 679 ms 633 ms their equipment

6 634 ms 676 ms 680 ms [] now you are on the internet backbone

Report •

November 6, 2009 at 09:43:15
According to a configuration record I saved earlier, the router indicates the WAN address as I'll reconnect yet again and see if this changes.

Why this hop doesn't show up explicitly in the trace is beyond me (as though I need to point that out).


Report •

November 6, 2009 at 10:00:18
That certainly does not make sense. The modem port and the router wan port have to be in the same subnet.

On the router wan port what was listed for gateway and dns?

Report •

November 6, 2009 at 10:20:24
WAN address: 96:63:24.93
DNS: (and .251)

Again, it seems clear from the characteristic satellite delay of ~ 600+ms that the address is equipment at the ground station at their end, not the modem here, wouldn't you say?

Between us, we've put in enough time on this to exceed the cost of a new router - if only for its value as a diagnostic aid. Unless a miracle happens soon, I'm ordering one today. Might as well upgrade to n-class.

This router was important here initially because it has a built-in print server with a parallel port - but the printer it once connected to is long dead and the new printers are both network capable.

Oh yeah... gotta try a different power supply just to rule that out. Fat chance that'll do anything but I gotta find out. <sigh>

Report •

November 6, 2009 at 11:03:32
Thanks for your help guys. I can't spend any more time on this and I sure as heck can't ask you to. I just placed an order for a new router.

Hopefully I'll be back here next week to report that all is well. If not, it means the new router didn't fix the problem and I've strangled myself with a Cat5 cable.


Report •

November 11, 2009 at 08:24:34
I had a thought while waiting for my new router to arrive.

As crazy as it seems for the router to spontaneously begin filtering port 80 or otherwise screwing up http traffic, it could conceivably come down to one flipped bit in the firmware. It's in EEPROM after all, not etched in granite. If I had a copy of that firmware, it's possible that reloading it might restore the router to normal operation. Wish I could've tried that.

Note to self: make back-up copies of the firmware for any field-upgradeable device -- before the manufacturer stops supporting it.

Report •

November 17, 2009 at 15:29:12
New router went in today. No further problems. No surprise.

Thanks again for trying to help, but I think we were doomed by a hardware (or firmware) fault. Resetting to factory defaults should certainly have restored web access if the issue was something I'd done, or a random glitch.


Report •

November 18, 2009 at 06:27:19
Glad it worked out and thanks for posting back.

Report •

Ask Question