Remote access to NAS device

April 28, 2011 at 09:42:53
Specs: Windows XP
I am looking to get remote access to my NAS device.
Please only respond if you have practical experience (that means you have done this... I have seen too many posts out there from people who think how this should work, but no actual experience doing it) and you have a similar setup.

I have a Lacie Net Space Max that advertises that it can be accessed remotely over the internet. They even provide a video which teaches you "how to setup a dynamic dns" and how to enter your dyndns host in the Lacie's user interface... and that's it. As if that were enough to access the device from the internet. (very disappointing).

I have, as many internet users do, a DSL modem (westell 7500 fro verizon) to get internet access.
That DSL modem connects to a Switch (no IP assigned to the switch).
Connected to the switch I have several net devices (all with static IP addesses like
A desktop (xxx=14),
A laptop (xxx=125),
A network printer (xxx=3) and
The Lacie NAS (xxx=198).

The DSL modem internal IP is
The external ip is whatever Verizon gives it from time to time. Lets assume it is just for the sake of this question. No DHCP service is provided by the DSL modem to the internal network.

This modem has its own Firewall, with various levels of protection (high, medium, low, none, and custom).
Each level has its own set of open ports (I can not see what they are). I have set it up at high.
The DSL modem also has a Port forwarding feature, with only one entry in it:
Rule Name Mode Host Action
IPSEC ALG Client Dynamic

The IPSEC rule is defined as Protocol=Both(tcp,udp), Global Ports= 500, Local/BaseHost Port= 500

I am not a network expert, but I assume that IPSEC must be a necessary active forwarding rule to allow the DSL modem to pass thru all the incoming and outgoing traffic from and to any of my computers.

No other ports seem to be forwarded, not even port 80.

Now, from inside my network, if I browse I get to the Lacie User interface (UI), which means port 80 is listening on the Lacie's web server.

Obviuosly, if i browse to, I get to the DSL modem's UI, form inside my network, which means the modems web server is also listening on port 80.
If I browse to (the external dsl modem's ip, given by verizon) I also get to the modem's UI, whcih means, its web server is also listening on port 80 for that external IP address. This means, with this ISP service I may not be able to forward port 80, otherwise I would not be able to access the modem's UI from outside.

I have tried to port forward to access my NAS as follows.
Created a rule
name= NASLacie50080 where the protocol=tcp, mode=Host, Host=, global port=50080, local port=80
with the intention of browsing and have the DSL modem detect a request to port 50080 and forward it as port 80 to

but I get this error
Unable to connect
Firefox can't establish a connection to the server at
(I masked the actual external IP address) I have pinged this URL and the IP resolves
fine, but it does not mean the port is responding

This could mean that port forwarding function of the modem is not really working (please do no suggest to reset or reboot the modem. I have already done it, multiple times, or to reboot the Lacie drive.., done that too).
I do not have access to the NAS OS (I think it is linux based), So I cannot test if port forwarding is actually going to it.
Since I have an internal webserver running on my desktop (, I also added a forwarding rule to forward port 50280 to port 80 on Then browsed to I get the same error
Unable to connect
Firefox can't establish a connection to the server at

Does anyone have an understanding of what may be happening? and how to make thsi port forwarding thing to work well? Please only if you have practical experience making something like this work.


See More: Remote access to NAS device

Report •

April 28, 2011 at 11:41:57
That "modem" is a router. Modems don't have features like port forwarding or nat.

Did you set the Nas to listen on port 50180 ?
Did you go to shields up! and do a custom port test on port 50180 to see if its listed as open?

You can not from your interna network establish a connection using the public ip. That would in effect be bouncing the packets off the wan interface which normally results in the packets being dropped.

You may wish to enable RDP on your workstation and forward port 3389 to your pc then from a internet cafe try to connect usingRDP and wanipaddress:3389 to see if you can test if forwarding is working on the unit at all.

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's

Report •
Related Solutions

Ask Question