Solved Problem with a Belkin wireless router

Belkin Surf n300 wireless n router
February 18, 2012 at 09:59:38
Specs: Windows XP SP3, AMD Athlon 2GHz/512 MB RAM
I am having trouble with a Belkin Surf N300 wireless router I bought a month ago. I made all the necessary ethernet cable connections, and I turned on the router and my modem. The "Internet" light on my modem was on, which tells me I have a working internet connection, but I got a red light on my router. For some reason, the router will not complete the connection. I've tried resetting/restarting the router and restarting the computer, and am about to try restarting the modem. Nothing has worked so far. Can anyone help me?

See More: Problem with a Belkin wireless router

Report •

February 18, 2012 at 22:12:23
✔ Best Answer
Have you used a wired connection from the PC to router to log into the router admin interface and check whether the WAN settings have been auto-configured?
I presume you can get internet by connecting directly from PC to modem.
Sometimes the ISP sets the modem to only recognize the original PC by it's MAC address. If this is the case you need to clone the PC's MAC in the router in order for the router to be accepted by the modem. In other cases there are ISP specific settings that have to be altered in the router in order to establish a working connection to the modem. Your ISP may or may not assist answer these questions.
I know from past experience that my ISP's tech support ends at the modem. They will not provide assistance with router issues but there's no harm in asking.

Goin' Fishin' (Some day)

Report •

February 19, 2012 at 08:45:47
Thank you so much for your help! I cloned the PC's MAC address in the router and everything seems to be working fine now. I would have never figured out that cloning the MAC would fix the problem.

Report •
Related Solutions

Ask Question