Portforwarding dont work

November 2, 2009 at 08:04:42
Specs: Macintosh
im trying to do port forwarding, but it doesnt work on dsl 1000ER modem router on my singnet broadband connection.

I'm running a apache webserver on 5555 and had it port forwarded to. But i can access through the external ip address.

I asked my friend to access my IP and port 5555, but they can't view the page.

I'm sure all my pc/webserver all worked as i've tried it with my linksys router before. It worked. But after switching to singnet and using aztech router, i can't.

Singnet has claimed they did not block any ports for my IP.

Now that port forwarding can't work, i am sure if i open up the ports for gaming as well, it will not work as well. Can anyone assist me with this. could it be the router's fault or firmware problem?

please see screen shot and detailed problem at


any helpers ?

See More: Portforwarding dont work

Report •

November 2, 2009 at 09:05:05
You did bind the static ip to the apache server?
You did set the listening port to 5555 in apache?
You are trying to access via the web at wanipaddress:5555?

Report •

November 2, 2009 at 15:14:23
yes i did if you see my screenshot in my blog

Report •

November 2, 2009 at 15:57:51
Sorry your screen shots/blog didn't tell me any more than your original post. Still lacking the details which is why I asked three very specific questions.

BTW your dhcp scope is wrong unless you are doing ip reservations. Since the server is set at the scope should be from .3 to 253.

Report •

Related Solutions

November 2, 2009 at 18:24:18
hi thanks.
my screenshot did show i am accessing thru wanip:5555 and my apache works on which means my apache port listening to 5555

hmm , not quite sure what you mean wrong. is assigned to my pc that has the webserver running, so what is my scope wrong ? if i set .3 to .253, my pc ip address will changed to .3

Report •

November 3, 2009 at 01:00:21
what I see strange is it's asking for two addresses??

Why would the router need you to specify the forwarding address twice? I've never seen a port forwarding config that requires you to type in the same address in two boxes...I can't find any guides for that router though.

Maybe one of them is suppose to be the external (public facing) address?? You will normally need to set that up if the router has multiple interfaces. Try your external IP (The 116... address) in 'Remote host' - also try swapping them around if it doesn't work.

Just a guess.

Also - I would verify that the server is not seeing any traffic on port 5555 - if it is, then the server is probably misconfigured. You can check it with something like:
sudo tcpdump -i en0 -s0 -A 'port 5555'

(en0 or en1 for OS/X - get it from ifconfig, you'll also need a password on your account to use sudo)

If you see any traffic in tcpdump, then the problem might not be w/ the router.

Report •

November 3, 2009 at 08:10:30
any time you do port fowarding you forward to a STATIC ip never a dynamic ip. You need to give the web server a static ip. Hence my advice about the dhcp scope.

DHCP means your server could get any ip address in that scope. This could also be the reason your port forwarding isn't working.

" which means my apache port listening to 5555"

What happens if you just put in

Report •

November 4, 2009 at 02:54:27
If you see properly my description.. I am sure my webserver is on .1.2 although it might change to .3 , .5 because of Dchp i'm still forwarding it to the correct ip cos i checked my webserves ip before i forward So forwarding there is correct ..

Report •

November 4, 2009 at 07:57:07
Always examine what you believe to be fact when things are not working.

How about setting a static ip at .2 on the server? bind the port 5555 to it. Run the test that Fist suggests.

Report •

November 5, 2009 at 02:50:55
Thanks wanderer and fist .. But all suggested dun work... I'm sure dchp or static is not the culprit.. Either should work provided you forward to that exact address.. What about ip filtering.. My router says it blocked incoming ip from default.. Not sure if this the culprit... Shall i add a filter to my external addr ?

Report •

November 14, 2009 at 21:46:54
i reckon is because my connection settings has firewall enabed by default.. it says

"Meanwhile, all incoming IP traffic from the WAN is blocked when the firewall is enabled. However, some IP traffic can be ACCEPTED by setting up filters."

however there is no where i can find the firewall option to be disabled, this modem is integrated with my ISP dialup dsl and the PPPoE connection settings i cannot edit... Argh!

Report •

Ask Question