Click here for important information about

Port Forwarding Router Problems

Take 2 interactive Borderlands (pc)
February 28, 2010 at 03:03:15
Specs: Microsoft Windows XP Professional, 2.411 GHz / 3582 MB

I use an Airlink AR525W router for my home network and I discovered a rather inhibiting problem it has with trying to forward ports for game hosting: It won't.

My roommate and I use the same router to connect to the internet. In order to host a game of Borderlands, one of us must apparently forward ports 7777, 27900, 28900, 28902, and 28910. I've tried and tried to get my router to forward these ports, and I've disabled firewalls, but it still won't work.

I followed directions from to get to my router settings, and everything seemed to work great. When I'd finish changing the preferences I'd click "Apply" to save settings, and then the router would reboot like it should.

However, when I use a client program to check if a specific port is open, it always gives me the same message: "Your port NOT OPEN is not open or not reachable!".

I'm not sure what I'm missing here.

Oh, and when I try to simply DMZ my router, it will not allow me to apply my settings, (I click the "Apply" button, but nothing happens) so DMZ altogether will not work.

P.S. If I just need new drivers, that would be annoyingly inconvenient as well as simple and convenient. For some reason, the Airlink driver for this router is an image file (dff), yet PowerISO will not open it!

See More: Port Forwarding Router Problems

February 28, 2010 at 06:56:37
Your question has nothing to do with CPUs or overclocking. Please post in the correct forum....try Networking or Hardware.

EDIT: post was moved by moderator.

Report •

February 28, 2010 at 12:29:00
I didn't mean to post it there. I was completely sure that I was posting it here in Networking... At 2:00 in the morning.

Report •

March 1, 2010 at 07:25:38
Either a router can or it cannot port forward. If your router's management interface has a place for configuring port forwards and they don't work no matter what you try, then it's entirely possible there's something wrong with the router itself.

The first thing I would do is check for a newer version of the firmware. If there is one, download and apply it and see if that doesn't fix the problem.

If it doesn't you will likely have to call the manufacturer's support line as they're likely to be the only ones that can help you.

Report •

Related Solutions

March 1, 2010 at 08:19:31
I see no mention of assigning your pcs a static ip address. You can't forward if you don't have a set ip to forward to.

Instead of forwarding consider opening.

Your ports list appears to be shy
TCP: 7777,28900-28902,28910,29900
UDP: 6500,7777-7787,9989,27900

Report •

March 1, 2010 at 23:17:04
Thanks for the support. I'm really thinking it's a problem with
the router. I can't install firmware for this discontinued router
as it's an image format that for some reason WILL NOT open
in any with any program, even PowerISO. So, yeah...

I have set a static IP address. As I've said, I followed the
instructions in the link above.

I've had a hunch that's it's all the router's fault, but now that I
can't seem to get anything to work... Sigh...

I just didn't want to give up on what is in every other case a
much more stable and reliable router than any other router I've

Report •

March 2, 2010 at 05:55:36
The guide you followed did not list all the ports I found needed to be opened/forwarded. For example 6500. Certainly explains why you get the port not open message.

You should not need new firmware to do a basic function.

Report •

March 3, 2010 at 12:55:19
I know it did not list all of the needed ports, but I had looked up
the ports needed off of a Borderlands forum...

But that does not matter since the port checker program says
that none of the ports are open, listed or not.

Report •

Ask Question