Port 80 not forwarding?

Cisco Linksys e3000 high performance wir...
August 27, 2011 at 10:18:53
Specs: Linux, 4GB
I am upgrading from a Netgear router to an E3000 Linksys. My router sits behind a DSL modem and I run a small business website on a Linux server and perform dynamic DNS updates. I have replicated the full configuration of my old router over to the new Linksys, but my webserver is not available from a WAN address. It works fine from the LAN address, but using the fqdn or the ISP provided IP address does not provide access.

o The webserver LAN address is static at
o The routers DHCP addresses are from .105-.150.
o I've tried reserving address .101 and changing the DHCP range with no change.
o I have port 80 forwarded to the .101 address
o LAN access to outside sources from wired and wireless devices works fine.
o My ISP assigned address is 98.66.30.xxx (DNS lookup mirrors this.)
o The router internet address is
o NAT is enabled.
o No webserver connections from either the fqdn or the ISP provided address.

The setuup has been working well for a long time, but I can't seem the get my new router to direct external traffic to the webserver. Please let me know if you see something I've missed or mis-configured.

See More: Port 80 not forwarding?

Report •

August 27, 2011 at 12:50:01
The webserver LAN address is static at

The router internet address is

I dont know what you mean by the routers Internet address. The routers Internet address is the assigned by your ISP

Do you mean the gateway address, in which case that is where your problem lies. The Gateways address and the LAN are on two different networks. Makes them both 192.169.1.x or 192.168.0,x.


Report •

August 27, 2011 at 13:33:46
Thanks for the reply. Yes, I think the 'IP address' of the router is odd. My netgear shows the ISP assigned DHCP address for the internet address, but the Cisco stays at 192.168.1.xx.

As a test, I've put the Netgear back in and verified the previous setup and settings. I attached the Cisco internet port to a Netgear port (x-over cable...) and the IP address is showing up as one of the DHCP assigned addresses from the Cisco. For some reason the cisco isn't getting the ISP address passed through from my modem.... (?)

I'll dig on this a bit further, but you've helped me get pointed in the right direction!
(Back to the office....)

Report •

August 29, 2011 at 00:17:03
Problem Solved! It turns out my modem was in PPPoE/IP Pass-through mode and not in 'bridged ethernet' mode. After setting modem into 'real' bridged mode, I set my ISP login/password in the E3000 PPPoE setup screen. With the setting saved and the router restarted, the internet address now showed the public ISP address and my webserver was accessible from the internet.

Thanks for the suggestions and help! The Linksys chat techs I worked with were both on target with needing to set the router to PPPoE. I'm not sure why my old Netgear worked fine with the IP pass through mode on the modem, but the Linksys E3000 is working great now.

Report •

Related Solutions

August 29, 2011 at 04:21:13
Thanks for letting us know. It is the simple thing that is often overlooked that solves these problems.


Report •

Ask Question