Pinging local computer names fails

March 2, 2009 at 06:19:28
Specs: Windows XP we go. I'm having an issue with one computer on a network not
being able to ping other computers by name. I've spent the last day
searching similar issues and I've tried all the steps recommended. If
anyone has some suggestions, I'd love to give them a try - this is driving me

I am connected via wired-LAN to a Linksys WRT-600N router; there are 4
other computers on the network. The other 3 computers are working
perfectly - they can browse the network neighborhood and ping other
computers by name.

The problem computer is set to the same workgroup and cannot browse My
Network Places ("Workgroup is not accessible") and cannot ping the others
by name. When I try, I receive "Ping request could not find host
COMPUTER1. Please check the name and try again." It does not even
attempt a ping. It can, however, ping by IP address. I can also ping internet
sites by name and it correctly resolves to the IP address.

Here's some info, and steps that I've tried:

1. The TCP/IP settings are set exactly like the other computers (DHCP,
default NETBIOS setting, and Enable LMHosts is checked).

2. The HOSTS file is present and contains only the typical single entry (as
do the others)

3. I have tried "Enable NETBIOS over TCP/IP" with no luck

4. I have tried static settings with no luck

5. I have done a full virus scan and spyware scan and everything is clean.
The computer also has no other "weird" issues.

That's all I can think of. Any help would be really appreciated. Thank you!


See More: Pinging local computer names fails

Report •

March 2, 2009 at 07:10:36
what abt the services running in ur PC's..
some virus may stop the below listed services ..
there's a chance so check
u can compare it with the other PC's in ur Network..
and also im giving some services beloww

check whether the following services are runningg..

Alerter Service
Application Layer Gateway Service
Application Management Service
Computer Browser Service
Cryptographic Services Service
DCOM Server Process Launcher
DHCP Client Service
DNS Client Service
Error Reporting Service
Event Log Service
Fast User Switching Compatibility Service
Indexing Service
Internet Connection - Firewall (ICF) / Sharing (ICS) Service
Net Logon Service
Network Connections Service
Network Location Awareness (NLA) Service
Network Provisioning Service
Performance Logs and Alerts Service
Print Spooler Service
Protected Storage Service
QoS RSVP Service
Remote Procedure Call (RPC) Service
Remote Procedure Call (RPC) Locator Service
Remote Registry Service
Secondary Logon Service
TCP/IP NetBIOS Helper Service
Telephony Service
WebClient Service
Windows Audio Service

and also wht abt accesing the shared foledr using IP address..

Report •

March 2, 2009 at 07:45:56
if its not the prob try this one also to reset the TCP /IP protocol..

start >run > type 'cmd'
from there type below given command
netsh int ip reset c:\resetlog.txt
will reset the following registry keys and provide a logfile @ c drive..


Report •

March 2, 2009 at 08:03:39
Is anything shared on this problem pc? If not do so.

Make sure all software firewalls are configured not to block this pc and they are all configured to trust the local subnet.

Report •

Related Solutions

March 2, 2009 at 10:02:14

Thanks for the suggestions. Here's what I found:

1. All services appear to be running normally (i.e. same as other machines)

2. Tried resetting the TCP/IP protocol, the logfile is below.

3. The only firewalls running on the PCs are Windows Firewall. I tried disabling this completely.
I'm not sure how to configure it to trust the local subnet, although I'd imagine disabling it takes care
of this.

4. I can access a shared folder on another computer via IP address.

5. Tried unsharing / re-sharing a folder.

I'm still not able to ping any local computer by name. I also found that the other computers cannot
ping the "broken" computer by name either. They can ping by IP address, though.

Thanks again for the help - and please let me know any thoughts.

Here's the log-file from the TCP/IP reset:

reset SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_{AE66CE4A-604D-
old REG_DWORD = 1

deleted SYSTEM\CurrentControlSet\Services\Netbt\Parameters\EnableLmhosts
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{4AB5694C-CA76-48E0-
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{4AB5694C-CA76-48E0-
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{4AB5694C-CA76-48E0-
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{AE66CE4A-604D-450F-
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{AE66CE4A-604D-450F-
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{AE66CE4A-604D-450F-
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DontAddDefaultGatewayDefault
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableIcmpRedirect
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableSecurityFilters
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SearchList
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\UseDomainNameDevolution
reset Linkage\UpperBind for
PCI\VEN_8086&DEV_4222&SUBSYS_135B103C&REV_02\4&4878531&0&00E1. bad value was:

reset Linkage\UpperBind for
PCI\VEN_14E4&DEV_16FD&SUBSYS_30B1103C&REV_21\4&BF41672&0&00E0. bad value was:

reset Linkage\UpperBind for {95C7A0A0-3094-11D7-A202-
00508B9D7D5A}\BTWDNDIS\1&30EE4AD&0&1000000020000. bad value was:

reset Linkage\UpperBind for ROOT\MS_NDISWANIP\0000. bad value was:


Report •

March 2, 2009 at 10:54:32
Is anything shared on this problem pc?

I don't see a specific response to this question.

Report •

March 2, 2009 at 13:28:24
Sorry, I should have been more sharing is enabled and
there are multiple folders shared from this PC. In fact, I can
access the folders if I browse to the IP address from another



Report •

March 2, 2009 at 14:30:28
I have seen posts similar to yours and the solution is still a mystery. Usually netbios enabled solves this issue.

Next step is to do static ip assignments, create a hosts file that has each host listed along with its ip address. You place this file in the etc subfolder on each system.

This always works because the host information is cached upon boot.

But perhaps you may want to download browstat from microsoft and see who is your master browser

Report •

March 2, 2009 at 15:24:51
Solved! Thanks for the heads up on browstat, that's what led me
to the solution. It was reporting no master browser could be
found. In addition, IPCONFIG was reporting a node type of "Peer-
Peer". A bit of Googling led me to this KB article:

I made the registry change and it now works once a again.

Any idea on how this could have changed?

Again, thank you!!

Report •

March 2, 2009 at 21:10:55
Only thing I can think of that may have put those registry entries in would be if you tried out bridging or using ICS for internet access. It really could be anything from a program install mod to minor disk corruption. Something got lost somewhere.

Good job on the google search. That article described your situation perfectly.

Report •

Ask Question