Pinging DC IP but cannot resolve DC name

Microsoft Windows xp professional with s...
July 17, 2010 at 22:28:27
Specs: Windows XP

I am surprised why one computer of my network is not joining to Domain while all others have joined and already working with no difficulties or technical issues. Just one computer running Windows XP SP2 cannot join to domain as it returns with pop up stating the Domain "xxxxxxx" cannot be contacted. I wonder if DNS is a real issue how other computers using same OS are able to resolve the domain name and accessing network and its other resources. I will be grateful if any one can give me a clue, as to how I can counter this issue.

The things I have tried:

Obtain IP Address automatically - not working
Configured IP manually - not working
Uninstalled and re-installed NIC drivers - not working
Replaced NIC - not working
Upated computer with Microsoft Automatic Updates - still no use
used nslookup <dc name>- it shows DNS request timed out and it gives me can't find server name for address

My IP Configuration:

IP Address:
Subnet mask:


Where is a DSL modem IP.

Domain Controller IP Details:

IP Address:
Subnet Mask:


Please HELP

Thanks in advance.

See More: Pinging DC IP but cannot resolve DC name

Report •

July 17, 2010 at 23:27:29
I'm a total novice when it comes to domain connections but your gateway IP of could be your problem. The modem IP would normally one allocated by your ISP and would be a public IP not a private one in the range.

If that is in fact a modem IP then a device using that as a gateway would only be able to contact upstream (WWW) addresses. Your DC is downstream of the modem.

I could be wrong but would not a system joining a domain normally have the DC 's IP as it's default gateway?

Goin' Fishin' (Some day)

Report •

July 17, 2010 at 23:36:15
Thanks Richard for your effort. BUT the modem ofcourse is having a public IP and with NAT enabled to give the gateway IP as stated in my previous posting. However, it is the same IP on all other systems connected and working fine with no difficulty. Any other Clue PLEASE

Report •

July 18, 2010 at 00:04:59
Is it a modem or a router? I wasn't aware a modem was capable of doing NAT. What device is providing your DHCP?

Goin' Fishin' (Some day)

Report •

Related Solutions

July 18, 2010 at 00:09:45
Even the DHCP is provided by a Modem in my case. This is the modem provided by an ISP.

Report •

July 18, 2010 at 04:22:37
Any one around... please help me in this regard. I am confused as to why this system not joining domain. I am clue less. PLEASE somebody come forward and help me

Report •

July 18, 2010 at 05:46:02
Only other thought that comes to me is whether the operating system is XP Home or Pro.

If it's Home then there's your problem.

Goin' Fishin' (Some day)

Report •

July 19, 2010 at 09:01:44
Richard for your information a pc joining a domain never has the server as a gateway, unless the server is also acting as a router.

mkmshahid since everything else is working your only issue is with this xp station. Don't mess up your network thinking its outside of this pc that is the issue.

Is this a xp home pc?

Post the results of an ipconfig /all from this problem pc for review

Report •

July 19, 2010 at 23:07:07
As Richard mentioned in Resp # 3, I would like to clarify. The ISP actually has provided NetGear Router which acting as a modem as well.

For Wanderer I am pasting the result of ipconfig/all....

Ooops I can't use Ctrl+V here to paste.

For both of you, The OS is XP Prof with SP2, which is user for any other computer in the same network which afre joined to domain and working successfull. Any thoughts..... PLZ

Wanderer, how can I share the Screen Shot with you.

Report •

July 19, 2010 at 23:45:42
Wanderer I am hereby presenting the ipconfig/all info:

Microsoft windows XP [Version 5.1.2600]
<c> Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\IT>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . .. . . . . : badar
Primary Dns Suffix . . . . . . :
Node Type . . . . . . . ... . . . . : Unknown
IP Routing Enabled. . .. . . . . : No
WINS Proxy Enabled. . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specifix DNS Suffix . :
Description . . . . . . . ....... . . . : Realtek RTL8139 Family PCI Fast Ethe
rnet NIC
Physical Address. . . . . . ... . . : 00-0D-87-64-E6-D6
Dhcp Enabled. . . . . . . . . . . . . : No
IP Address. . . . . . . . . . . . . .. :
Subnet Mask . . . . . . . . . . . .. .:
Default Gateway . . . . . . . . .. . :
DNS Servers . . . . . . . . . . . . . :

C:\Documents and Settings\IT>

I hope this will you to guide me to counter the is problem.

Report •

July 20, 2010 at 07:32:06
"Dhcp Enabled. . . . . . . . . . . . . : No"

So all of your computers are using Static IPs?

DNS Servers . . . . . . . . . . . . . :

Is this the IP address of you DC running DNS?

And can you post the results of pinging the Server by name? My guess is you local cache is not up to date. Try a simple...


This will download the FQDN information from your DNS server to your local cache. Try the ping again and see if it resolves.

Report •

July 20, 2010 at 23:04:37
Ace_Omega the system still not resolving DNS after using ur suggested ipconfig/flushdns and ipconfig/registerdns. Yes, the DNS Server is the same Domain Controller, I can ping by IP but cannot by DC name, it returns with message, Ping request could not find host "<xxxxxxxxxx>". Please check the name and try again.

About the DHCP, let me clarify all the computers obtaining IP from DHCP. I have tried using the IP manually. Since it was not working with Automatic IP.

It is really embarassing situation for me, I could not resolve this issue for more than 4 days now. Please HELP me.

Report •

July 21, 2010 at 07:36:38
Sorry, it looks like you tried the usual suspects time to look at some others. If you can resolve FQDN from other computers but not this one then there has to be something different with this computer and nothing wrong with your DNS. So what might be different? What OS is it running, does it have any IPS or AntiVirus that is different, is its firewall configured different? I would look at the firewall and make sure you are not blocking port 53 or do a simple port scan on this computer and compare it to one that is working.

I hope this helps. Trouble shooting takes time and over a forum it takes even longer. Worst case you could try backing up the files and re imaging the computer.

Report •

July 21, 2010 at 08:09:15
mkmshahid does a host and ptr record exist in your dns server for the server? This is the first thing you check. Does not appear this entry exists.

Please post a ipconfig /all from your server for review.

Report •

Ask Question