No internet connection after XPsp3

February 18, 2009 at 04:27:06
Specs: Windows XP
I just installed service pack 3 for XP home edition. Right before I did it, my internet connection was working fine. Immediately after the instal, I lost my connection. Doing a system network scan, it says the DHCP server is not assigning my computer an IP address. This is a desktop computer, connected via cable to my Linksys WRT54GS router. I have cable broadband internet. I know the router and internet connection are still working since I have a laptop and several mobile divices that are actively using it.
After rebooting the computer, router and modem several times, I called Microsoft help. They walked me through a few simple things, then had me uninstall SP3. Still no success. They told me to contact my ISP.
The hardware appears to be working-- the green LED lights up when the network cable is plugged in and the network icon in the system tray responds when the cable is plugged/ unplugged. It says "limited or no connectivity".
Any ideas as to what I should try next?

See More: No internet connection after XPsp3

Report •

February 18, 2009 at 05:35:36
First look at the device manager to see if the NIC drivers were damaged. Then try a static IP.
Post ipconfig /all results if you still have a problem.

Report •

February 18, 2009 at 20:57:55
Checked the device manager and it says the card is working properly.

I then tried to create a static IP. Once I set it up, windows indicated that the network connection had full connectivity, but I could not pull up a web page in the browser. (To set up the static ip, I copied the subnet mask, default gateway and DNS servers addresses from my other computer which can connect. I gave it a different IP address, of course).

One thing I noticed... both the router and my other computer have the subnet mask set as, while my problem computer, when DHCP is enabled, has a subnet mask as Shouldn't that be the same number? Can I change that?

IP config info for the problem computer:
Windows IP Configuration

Host Name . . . . . . . . . . . . : DESKTOP_01
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
Physical Address. . . . . . . . . : 00-0E-A6-24-57-B5
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :

Any other ideas to try?

Thanks for your help!


Report •

February 19, 2009 at 05:39:18
That ipconfig doesn't show a static IP and yes, the subnet mask should be the same as the other PC. Set everything manually including the default gateway, which is the IP of the router.

Report •

Related Solutions

February 19, 2009 at 21:51:10
I tried that. When I set everything manually, my "network connection" goes from "limited to no connectivity" to "connected", but I still cant access the internet or see other shared drives.

When the router is set up through DHCP to assign IP and a subnet mask of, then why does my computer have a subnet mask of Is that a defaul windows thing? Does that mean I'm not communicating at all with the router?

I also tried bypassing the router and just connecting to the cable modem with the network cable directly. It just says that my network cable is unplugged. wierd. Are some modems only set up to work with routers only?

Report •

February 20, 2009 at 05:25:50
When you see that address, there is no communication with the router.

"Autoconfiguration" IP Addresses: -

Addresses in the range to are used automatically by some PCs and Macs when they are configured to use IP, do not have a static IP Address assigned, and are unable to obtain an IP address using DHCP.
That's why I suggested the static IP. If you connected the PC directly to the modem without the static IP and still didn't get a connection, then the problem is your NIC.

Report •

February 21, 2009 at 06:05:54
Took the network cable from the problem desktop and connected my laptop to the internet successfully. I don't think the problem is the router.

So I'm focusing on the NIC (Intell PRO/100 VE). I downloaded the latest drivers and installed them... still no connection.

The device manager says its working. Ran various hardware and software diagnostics on it... it passes everything.

If I knew it was bad, I would go spend $40 for a new one and that would be it. But how can I know for sure it is that NIC?

Report •

February 21, 2009 at 16:41:54
I ran into a few of them where I had to delete the NIC completely, reboot and let Windows find it as new hardware when an uninstall and reinstall didn't work. Make sure you have the drivers on a CD if you try it.

Report •

February 21, 2009 at 20:00:29
Fixed it, finally! In desperation, I tried uninstalling everything governing the internet usage... security, antivirus... then I found an old earthlink Total Access program from when they were my service provider several years ago. It ran at startup even though I never used it. That was it! As soon as I uninstalled that, everything worked beautifully. SP3 must have finally put it over the edge.

Thanks for your help, Guapo!

Report •

February 22, 2009 at 05:36:26
Excellent!!!! I'm glad to hear it.

Report •

Ask Question