Solved Network Connection Problem - OS? Software? Hardware?

Toshiba Satellite p770-bt4n22 customizab...
January 4, 2016 at 17:00:43
Specs: Windows 64 Ultimate SP1 64bit, i7 4790 \ 32GB DDR3
I'm running Win 7 Ultimate 64 bit SP1 on an 850 EVO SSD

My system specs
17 4790
Gigabyte GA H97 D3H mobo
XFX R9 390
32 GB (4x8) DDR3
Seasonic S1211 620W PSU
1 x 120GB SSD
4 x 7200 HDD's

I've been having trouble with my computer not connecting or disconnecting form the internet. I'm running it wired through Ethernet only - never wireless. I have two other computers I rarely use - a desktop and a laptop and neither have this problem.

The problem is that sometimes the internet connection will just kick out on this main computer with the specs listed above. The Network Connect icon in the taskbar will show the yellow warning disconnected triangle, and hovering over it will show No Internet access. This has been happening off and on for quite some time. Like months. But the trouble in diagnosing the source of the problem has been that 1) it happens so sporadically and 2) sometimes the problem had been solved by right clicking the Taskbar Network connection icon and choosing Troubleshoot problem. But I think this was related to a second problem from a VPN.

I've been using a VPN, and Network connection problems can happen when VPN's create a second Network adapter connection. So the Network connection problem manifested as a DNS error. The Network connection troubleshooter had resolved it, reporting the solution in various ways, including:

"Resetting the Local Area Connection Adapter

The default gateway is not available"

In that case it reset the adapter and the connection was restored.

But it still cuts out again. And now after completely uninstalling the VPN using Revo Pro, the computer's Network connection still cuts out periodically for hours at a time, seemingly at random. After rebooting it will still be out. Using the Network Troubleshooter has brought up messages including:

"DHCP is not enabled for "Local Area Connection"

The DNS server isn't responding"


"Windows can't communicate with the device or resource (primary DNS server)"

Both of which the troubleshooter is unable to fix. On a couple of occasions I shut the computer down, turned off power to the comp from the power bar, waited a while and rebooted, and it came back on. But that no longer works at all.

Right now the Network connection is out again, and when I run the troubleshooter it just says "Troubleshooting couldn't identify the problem"

But my other two machines are still fine.

Like I said, this has been occuring sporadically over months now. Becuase I've been suspecting an OS or software problem or conflict I've been troubleshooting in that direction. I hadn't suspected a hardware problem

I am only running wired - never wireless. Other Troubleshooting attempts have included:
- Tried new Ethernet cables, and new coax cable to the modem. Plugged the cables into different ports on the modem
- Had my isp send me a brand new modem - even though that made no sense as the second computer has had no problem.
- Ran full Antivirus and Malware scans, including Avast, Malwarebytes, Adwcleaner, JRT and CCleaner.
- Re-installed Win 7 Ultimate after the problem had been going on for a while, but it started again soon after install
- Ran cmd prompt as admin and flushed the DNS using ipconfig /flushdns
- Ran cmd prompt as admin and the ran sfc /scannow which showed "Windows Resource Protection did not find any integrity violations."
- Under my main Network connection (with VPN completely uninstalled) I set IPv4 from Obtain IP Adress Automatically, to a manual address; also did the same for for DNS, manually providing both IP Adress and DNS address
- suggestions had included an Nvidia GPU drive related problem, but I've run both an Nvidia and AMD card in this time, completely uninstalling drivers with Display Driver Uninstaller
- Booted my computer into safe mode with Networking and it still had no connections
- In Safe Mode I Ran msconfig as admin and disabled all startup items. Rebooted and still no connections

At this point I'm now considering a hardware related problem with the Ethernet port on the motherboard. But could that be the culprit even though it sometimes still works? It seems to me the problem is happening more and more often, with longer down times. This is so frustrating and I've been unable to fix it. Any suggestions?

See More: Network Connection Problem - OS? Software? Hardware?

Report •

January 4, 2016 at 18:21:27
✔ Best Answer
Have you tried another Ethernet adapter?
Or USB Ethernet adapter ...

message edited by sluc

Report •

January 4, 2016 at 23:08:55
Ok sluc, I think you're on to something. I didn't try another adapter. But what I did is uninstall the current adapter in Device Manager, and then downloaded the Intel LAN driver from the Gigabyte website. It was the exact same version as I was using, but I re-installed it anyway and the Internet Network connection came back on after install.

Regarding your recommendation though ...

The mobo driver disk does also appear to have other drivers. Inside the Network Adapters folder on the disc were subfolders for Atheros, Bigfoot, Intel (the one I'm using), RTL other, RTL8111, and RTLTOOL. Just for a test, I uninstalled the Intel adapter again,and then tried the Atheros - it had a Setup.exe file. It launched the Setup and just started to try installing the Qualcomm Atheros driver, but halted with the error "Installer can't find Qualcomm Atheros AR81Family ethernet controller on your system".

So I exited and re-installed the Intel and again, it connected.

The Ethernet port on the Mobo, is listed as an Intel GbE LAN chip, which is why I originally installed that Intel LAN driver. I wasn't aware that I could install a different adapter. That is what you're saying right? Try using a different adapter? I mean it's working again now, but who knows for how long. If it kicks out again, should I just try to get a working version of the Atheros, or try the Bigfoot for example?

Also, I don't have an Ethernet to USB adapter.

message edited by Teemo

Report •

January 5, 2016 at 03:19:32
I meant to add an extra inexpensive PCI LAN port extension board.

Report •

Related Solutions

January 5, 2016 at 14:25:37
PCI LAN port extension board

These are generally referred to as a NIC (Network Interface Card) since they're an expansion card you add to your PC. These days they're all PCI or PCI-X but if memory serves me, my first one was EISA and ran at a whopping 10 Mbps.

If one of the other PC's in question has an actual NIC, you could shut that unit down, remove the NIC, install it in the problem child and see if it works properly. Barring that, you could ask friends/family to see if anybody you know has one you could use for a couple days to test. Alternatively, you could ask if any of the same people have a USB network interface.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***

message edited by Curt R

Report •

January 5, 2016 at 21:15:11
Also, get the latest drivers for your motherboard directly from Gigabyte, if you have not, this might solve it if the last reinstall does not and you continue to have problems. If that does not do it then adding a separate NIC card will probably be the best bet.

You have to be a little bit crazy to keep you from going insane.

Report •

Ask Question