Need to repair Network Connection every time

February 17, 2011 at 04:55:11
Specs: Windows XP, 3.058 GHz / 503 MB
In order to get an Internet connection, I have to go to Network Connections, Local Area Connection and right-click to "repair" every time. I have downloaded and used TCP/IP and Winsock repairs without result. I use WIN XP SP2 and run updated Avira, Malwarebytes and Spybot, all full versions, as well as Panda Anti-Rootkit. Nothing has been found recently. I am aware of damage left behind by deleted malware but don't know where to look. We work through a router, but the other computer has no such problem. This isn't dire of course - it only takes a few seconds to do, but I am curious and would be very grateful if anyone could suggest something to help.

See More: Need to repair Network Connection every time

Report •

February 17, 2011 at 06:47:11
You should have only one realtime scanner in operation; the others should be called on manually. I don't know if that's a factor here though.

Is your LAN connection clear in Internet Options?

Make sure you have IPv6 enabled under your adapter's TCP/IP settings. Compare them to those of the machine that's working.

Report •

February 20, 2011 at 01:42:10
Thank you for your help. I thought I'd made a reply to this, but it seems to have got lost in the post. I don't know how to carry out your suggestions 2 and 3 - could you spell them out for me?

Recently the whole thing got worse. Repair no longer works - stalls at "renewing IP address". I can run winsockfix but that also locks up sometimes. I note there are some ideas in winsockfix but they are beyond my poor brain to follow.

I have seen other posts for this problem here and other other sites but very few replies; it seems a tricky thing.

Would you expect it to be settled by re-installing Windows? That's a pain, as I have it customised, but this is a worse pain.

Report •

February 20, 2011 at 02:34:03
Go to Internet Options / Connections and check that the Lan Proxy is not enabled.

Then go to Network Connections, right- click on your connection / Properties, select IPv4 protocol and read its properties. Compare them to those of the working machine. Make sure IPv6 is also listed among the installed protocols.

If that doesn't work go Start / Run, type cmd. In the window type ipconfig /all > %userprofile%\desktop\ipconfig.txt . That should put a file on your desktop. Post its contents here.

Report •

Related Solutions

February 20, 2011 at 17:19:45
Sorry paul1149, I'm a pain in the neck. I can't find anything relating to ip4 there. When I ran the string in cmd, nothing appears. There is no error message, just reverts to C:\>

There should be spaces after ipconfig, after all and also after the "greater than" sign? The line-break in your message makes me uncertain and I've tried these all ways.

Would I be likely to put this right by re-installing Windows? It's familiar to me and less trouble for you.

Report •

February 20, 2011 at 18:54:47
No problem. Did you check your desktop? The file is probably there. It's:

ipconfig /all > %userprofile%\desktop\ipconfig.txt

Report •

February 20, 2011 at 18:55:41
You probably can copy and then paste it in with a right-click.

Report •

February 20, 2011 at 19:02:36
Yes, indeed; being a text file it's unmistakeable. I also checked in documents and settings and there's nothing there.

Did I enter the cmd line correctly - spaces etc? What about re-installing windows? That would be much easier in the end if it solved the problem.

If there's no problem with the laptop, can we eliminate any wrong setting on the router?

Report •

February 20, 2011 at 21:08:52
I had a look at this "Need to restart DHCP client every time" below. I ran ipconfig /release and found my IP and subnet mask were, the gateway being a blank. The suggested ipconfig /renew wouldn't run. It seems DHCP is used for two computers communicating - we have two but they aren't set to communicate.

Report •

February 21, 2011 at 07:14:41
Once you release the bindings it will say zero. /renew wouldn't run, or it ran unsuccessfully? If unsuccesfully, it sounds like your dhcp client is broken. You can try to repair it, you can go to a static IP instead of using it, or you can do a reinstall of Windows.

Repair: First, be sure the dhcp client service is running: start/run/cmd/services.msc. It must be set to an automatic start.
Next, try file checker: start/run type SFC.EXE /SCANNOW . You may need a retail XP disk handy.
If that doesn't work, remove and reinstall dhcp directly. See

Static IP: very easy. Turn off dhcp on the connection in XP. You may have to go into the router to see what IP range it accepts, but you could try something like Subnet mask: The default gateway is the router's address - probably You can verify that in the router or the other computer.

Reinstall: you can do a full install or a repair install of XP. The repair saves your apps and personal files, but will have to be updated. Full install wipes out everything.

Report •

February 21, 2011 at 16:49:19
DHCP client is set to auto.
I can't run SCANNOW, because I have to use my back-up copy of the original Windows, which was damaged. The system detects this.

I think it's much easier to re-instal, because this is getting tiresome - I have to run WinsockXPfix and re-start every time I switch on.

Thank you for your efforts paul1149 - I'm very grateful, but my knowledge isn't really enough to cope with some of this changes.

Report •

Ask Question