My wifi connection says excellent but can't connect to sites

July 17, 2016 at 17:12:46
Specs: Windows 7
Recently when i am on my desktop using google chrome the internet connection seems to bail out, rendering me unable to access websites and cuts out when i am on an internet based application disconnecting me from my session. The wifi connection says excellent but the performance says otherwise, my chromebook seems to have no issues, but i can't say the same for my desktop. plz help >.<

message edited by Hakaisha


See More: My wifi connection says excellent but cant connect to sites

Report •


#1
July 17, 2016 at 17:29:35
Best first step is to try the connection troubleshooter:
http://www.dummies.com/how-to/conte...

Always pop back and let us know the outcome - thanks


Report •

#2
July 17, 2016 at 17:34:56
It says the DNS server isn't responding yet i still have internet access

Report •

#3
July 17, 2016 at 18:16:52
Have you reset (power cycle) your router?
Do you have other devices connected to the router (wireless)? Same problem?

Report •

Related Solutions

#4
July 18, 2016 at 00:23:07
Also does it happen with more than browser?

Report •

#5
July 18, 2016 at 06:44:10
Open a command prompt window (Windows Key + R type in cmd and hit Enter) and run the following command: ipconfig /all

Post the results here so we can see them.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***


Report •

#6
July 18, 2016 at 06:56:48
Re #3
Don't be put off by the fact that it is only happening on one computer, I've known powering off/on the router fix that at times.

Always pop back and let us know the outcome - thanks


Report •

Ask Question