media not shared on complicated network

Amd Phenom ii x4 965 quad core processor
December 21, 2010 at 14:07:40
Specs: 7 ultimate 32bit, 2.9 GHz quad / 4gig
I'll try to make it as simple as I can.... but, My home network consists of 5 towers and 2 laptops. These are connected to 2 routers , the routers connected by ethernet ports 1 on both (I don't know what it's called, a link to link, not sure). tower 1 contains all the media, and is connected to router 2.
Now the easy bit is... every tower except tower 2 can access the media (laptops have no issue either). now even though tower 2 is connected to router 1, all other towers/laptops on router 1 have no problem accessing the media. now on this tower 2, I have joined the homegroup, I have setup sharing, the asy way and advanced way, going through all the permissions and stuff, I've made the passwords correct, and pretty much made sure everything I could do to allow access I did (I spent an entire day on it). yet it still refuses, yet tower 2 can access the "drive" but no permissions on any folders.
The best bit is, when I took the Hdd from tower 1 and slaved it to tower 2 (the media is on a second drive, not the primary), obviously tower 2 could access (had to take ownership, but hurrah), yet... No other tower could access it.
I'm no smart cookie, but it's clear to me that the problem lies with tower 2, and not my network.
So apart from a clean install, is there anything I can try to tell this tower to open up to the network, even though all permissions and firewall settings have been checked and double checked.

For info, I am using eset internet security on all towers, and I also set that to allow access as well as firewall exceptions.
Sorry for long post, I hope I made it as easy as I can.

See More: media not shared on complicated network

Report •

December 21, 2010 at 14:13:38
Oh, sorry, the modem is connected to router 1, but every tower has internet access no problems.

Report •

December 21, 2010 at 14:16:36
Ok, your network is not that complex.

Since everything else seems to be working fine with the exception of the one PC, it's most likely the problem.

Open a command prompt window on it and one other PC that isn't having problems connecting to your media server. To open a command prompt window do the following: Start >> Run >> type cmd and hit Enter

Once open, perform the following command on both PC's:

ipconfig /all

Now, post the output of both in a reply here in forum. Click on my name above and read my "how-to" guide titled: "Post the output of ipconfig (version 2)" for instructions on how to easily copy/paste from a command prompt window. While there, read my how-to guide on adding a second router. You seem to have already done so successfully, but a quick read-through won't hurt you any either. :)

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***

Report •

December 21, 2010 at 14:33:54
Well Curt R, within those few minutes of posting, I managed to achieve my result (typical). I tried right clicking the drive and folders on tower 1 (media) and choosing to "share with homegroup", but it stayed locked to "Media pc". So I tried to choose "specific people" instead, and physically chose tower 2, and it bloomin worked. After all those hours, and submitting to asking for help, the answer went and slapped me in the face.
So, many thanks for the reply and advice, and I hope it helps another soul to fix a similar issue.
Merry xmas to you, and all peeps.

Report •
Related Solutions

Ask Question