Solved Linksys wrt120n router behind TimeWarner cable modem EPX2203

September 15, 2012 at 01:53:57
Specs: Windows 7
My girlfriend changed to TimeWarner cable a while ago. I bought her a netgear wireless switch to have wireless access. She has an old laptop as well with Vista on it, and was trying to connect that to the WiFi. She asked a security guard from work for help, he let her buy the Linksys. Didnt solve the problem and he turned off the wireless security to connect the Vista laptop. That was somewhere July 2011. Since than I have setup MAC filtering to at least have the WiFi not completely open to the public.
Now all of a sudden the internet connection breaks, last month for the first time. Turned out that the Linksys didnt get a WAN IP-address from the cablemodem (it passes though the external address)
I rebooted the router no success, I rebooted the switch no succes. I have reset the router, didnt help either.
If I connected the PC directly to the router we had internet.
I disconnected the router turned it off and even took the battery out, connected everything and it was working again for about a month :(
I'm abroad at this moment so cant help her directly, have read that disconnecting the router for a longer period could help. But is there something that can be done to prevent this hassle monthly?

See More: Linksys wrt120n router behind TimeWarner cable modem EPX2203

Report •

September 15, 2012 at 21:21:19
have read that disconnecting the router for a longer period could help.

This is proof one should never believe all they read. Whenever I recommend someone recycle the power on their router, I tell them to unplug, wait ten seconds, then plug back in. Leaving it off for a longer period won't accomplish anything that leaving it off for ten seconds will.

When you say a wireless switch, I have to wonder if you mean a SOHO Router or an Access Point. To the best of my knowledge, there's no such thing as a "wireless switch"

Before I ask anything else, is a vista machine the only thing connecting? If yes, try connecting something with any other operating system and see if the same issue arises. If it doesn't, chances are the problem is vista. Just FYI, vista was a subpar offering from MS and for the majority stuck with it, it never worked right.

However, having said that, to me this sounds like the router is having issues. If recycling the power doesn't do the trick, or the frequency with which you have to do so increases, the next troubleshooting step is to ensure you have the most up to date firmware installed on our router. If you don't, donwload and install it.

If that doesn't fix the issue or you do have the most up to date firmware on it, I would recommend resetting the router to factory defaults and trying it again. If the problem persists, you may have a bad device and need to replace it.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***

Report •

September 17, 2012 at 06:25:30
✔ Best Answer
She has several things connecting to her wrt120n, android phone, security camera box, windows7 pc.
Three weeks ago we had the same issue that the cable modem was not forwarding the external address so the WAN address of the wrt120n was When I connected the W7 PC it worked straight away, so it is an issue between the cable modem and the linksys.
I tried powering it off and on, but that didnt bring any result, reset the cable modem and removed even the battery from it. That helped at that time but now we had the same issue and i wasnt around to help.
She powered everything down and plugged it in later, and it worked again. I have upgraded the firmware from to Hopefully that resolved the problem.

Report •
Related Solutions

Ask Question