limited connectivity to network with Vista

May 3, 2011 at 04:10:38
Specs: Windows XP
This computer has been in use for 3 years or so.
Windows Vista based.
Had trouble recently with nVidea 8800GT based graphics in that, after sometime in use, there would spurious lines accross screen.
Assumed was an overheating issue so did general clean out of dust.
Removed graphics card to clean out heatsink and fan.
On restart, problem was evident immediately despite removing and re-inserting several times.

Borrowed an older 7300 based card from a friend and now the graphics is working but cannot connect to local network. I do not understand what connection there could be between changing the graphics card and this problem.

Windows reports "limited connectivity" and "repair" options and diagnosis are unsuccessful and do not provide any more information (other than suggesting reboot of router).

We connect to the internet via a DSL Modem / Router.
Network "card" is actually nVidea based Gigabyte built on to the motherboard.
Next to the Ethernet socket is an LED which is woudl normally be green but is currently solidly Amber (unless speed is forced to 10Mb/s when it is extinguished). Another smaller LED flickers in response to router activity).
Change of cable and router socket tried.
It appears that the NIC does not successfully obtain an IP address.

Have tried:-

* Ping or Ping localhost - this appears to work.
* Ping other locations on network - none work.
* Ping this computer IP address (as allocated bt Router) from other locations - this fails.
* Switching off router for several minutes and restarting.
* Changing TCP/IP settings from "obtain IP adress automatically" to the specific IP adresses allocated by router.
* Disable of TCP/IP IPv6, leaving only IPv4.
* TCP/IP stack repair and reset of Winsock according to Microsoft knowledge base instructions.
* In Registry, set DhcpConnEnableBcastFlagToggle to 1so that Vista will try to obtain an IP address with and without using the Broadcast Flag in DHCP discovery packets.
* Changed TCP/IP setting for speed from automatic to "Full Duplex/10Mbps" (this resulted in Amber LED at NIC connector to extinguish)

There may be other suggestions I have tried but forgotten as I write this.
I still have the feeling that it is a software setting but will try next putting a Network card in a spare slot and disabling the motherboard NIC.

See More: limited connectivity to network with Vista

Report •

May 3, 2011 at 04:16:34
Forgot to say that I have also:
* Disabled and Enabled Network Connection
* Using Device Manager, deleted Network card so that it re-installed automatically on start-up.


Report •

May 3, 2011 at 08:48:30
Fitting a seperate LAN card, and disabling the motherboard LAN controller in the BIOS, fixed it with all other settings returned to normal. Must have been sheer co-incidence that the on-board LAN circuit failed when the graphics card was changed.

Report •
Related Solutions

Ask Question