LAC Limited / No Connectivity

Realtek / Rtl8139 family pci fast e...
June 28, 2009 at 13:52:25
Specs: Win2003Serv Standard R2, Core2Duo, 2GB
Hello, I have an HP Pavilion 752N, that used to be a PC. I backed up and reformatted, then installed my newly purchased copy of Windows 2003 Server Standard Edition R2. The server box (I'll just call it Box from now on) and the network have the following specs.

A Realtek RTL8139 Family PCI Fast Ethernet NIC.
A D-Link Rangebooster N Wireless Network Adapter, for use with
A D-Link DIR-615 (router on my network) connected to
A Motorola Modem, leased by Comcast, my ISP.

When I installed Windows 2003, it did not have any of the drivers for my computer in it, obviously. The ethernet driver was also gone. So, to be able to connect to the internet, I installed the Wifi adapter. It installed just fine, and I got on the internet. First things first, I installed all the security updates and windows updates before "unlocking" my internet connection as the Server setup wizard says. Then I activated my version of Win2003Serv via then internet, and registered, yada yada. Then I downloaded and installed all the drivers from the HP website: Display driver, Sound driver/Audio codecs, Modem, and finally, the Realtek ethernet NIC adapter.
I installed all of these and restarted, and it worked just fine. After a reboot, everything was as it should be. Adjusted resolution, and then I added the Domain Controller role to my server, which installed active directory and DNS. I also installed IIS server. I opened up the appropriate webserver ports in my router, and tried to http my box's IP address with another computer, and IIS is working fine, I was able to view the site just perfectly. It's been running in this same condition fine for 2 months. Now, I am installing another server box to my collection, an HP Pavilion A365C with 8 GB of ram and a good processor! woo! So I needed my Wireless Card out of Box. So, I figured, now that I had installed all the drivers for Box, the ethernet one should work. I plugged in an ethernet cable into Box, and straight into the LAN3 port on the router. Almost immediately, I get "Limited or no connectivity" on the connection, and windows assigns me an AIPIA IP address. 169.*.*.* etc. Hmmm. So I figure, okay, restart the router. Did that. No juice. Still the same Limited No Connection, and 169*** IP. Okay, so maybe it's the wrong port on the router, check to make sure Modem is plugged into WAN on router, and ethernet into LAN3. Then I tried LAN 1 2 and 4. Then I tried a different ethernet cable, one that was known to be working because it had connected a different server box previously. Still no connection.

Next, I tried manually assigning the connection a static IP. I went to LAC then properties then TCPIP then gave it My router is already assigned to I put for subnet, as typical, and then my router's IP for Default Gateway, and also, for DNS server. Still wouldn't connect. So I tried changing DNS server to itself, to Box's IP, as it was a DNS server and maybe that was the issue? That didn't work either. Okay, so now I'm thinking it's just a router problem. I tried connecting my other boxes to the router at the same time as Box, and they could all get IP addresses from the built in DHCP server in the router. Almost instantly. So I know the router is working fine. I also checked the settings in the router's web admin to make sure that it didn't have a reservation set for Box. All clear.

So, now I'm thinking okay it's a NIC issue. I disabled all other NICs, including the Wireless adapter, Hamachi, and 2 VMWare server adapters. Nothing is on but my LAC. Then I tried repair. Then Disable and Enable. And then CMD / ipconfig /release and /renew. After each of these, still won't connect. So now I'm thinking, okay, perhaps the NIC went bad, even though it worked 2 months ago back when Box was just a personal PC. Hmm. So I take out Box's realtek NIC and insert it into Box2. I install the same drivers as I did on Box1 (I was smart now, and stored them on a USB ext harddrive). Installed the NIC on Box2, and plugged in the same ethernet cord to LAN3 on the router, and sure enough it went and connected just fine. So what's up? It's not the NIC. It's not interference from other NICs. It's not the ethernet cable. It's not the router. It's not the IP settings in the router or in LAC properties. What do I need to do to get this working?

As a last resort, I tried completely uninstalling everything, all the adapters. Then I reinstalled just the Realtek one. I removed my router from the network and plugged my Box straight into the modem. Then I power cycled the modem to refresh the MAC address association from the router to BOX. Okay, now I wait and see that it says "Acquiring IP address". And I wait. And wait. And 2 minutes later, I get the same message. Limited Connection/No Connectivity. AIPIA ip address. *** is going on here guys? Anyone got any ideas? All other computers can connect, even with that same NIC. It's not the router or the NIC, it's gotta be the settings right? Did installing DNS and active directory goof up my IP settings? And if that's the case, how come I can connect with the Wireless Adapter to the router, but I can't directly connect to the router with Local Area Connection? (Oh and I tried creating a new Local Area connection 2.)

This is really frustrating me now. Anyone with any ideas would be greatly appreciated at this point in time. And if this turns out to be one of those DUH misconfiguration simplicities, I'm gonna sh*t myself. ;)

Short of reformatting and trying again, what options have I?

See More: LAC Limited / No Connectivity

Report •

June 28, 2009 at 13:55:13
Oh and PS, who decided it was a smart decision to make usernames on this forum CASE SENSITIVE? Jeeze luweeze guys I had myself re-registering only to find that my e-mail was taken (by me) and then I thought it was a password thing... then I sent myself my new credentials and it said my nickname was zackemo. Oh boy. Lowercase Z. Let's be unconventional.

Report •

June 28, 2009 at 15:24:47
No one has any ideas?

Report •

Related Solutions

Ask Question