intel 3945abg router & Vista

Intel / Pro wireless 3945abg
December 21, 2009 at 14:57:52
Specs: Windows Vista
i'm working on a system that had a lot of issues. it was running xp and had problems with wireless. I wiped the system and did a clean install of vista(basic).

I had to manually download the drivers for the wireless router. The system says it is enabled, but the wireless light will not come on and the connection under network connections will not enable. I have tried disabling/enabling the device, and I've tried uninstsalling/reinstalling drivers from the intel site, but it still is not working.

any suggestions?

See More: intel 3945abg router & Vista

Report •

December 21, 2009 at 16:08:22
Your heading and question are confusing. From Intel website: "The Intel® PRO/Wireless 3945ABG Network Connection is an embedded 802.11a/b/g PCIe Mini Card network adapter operating in the 2.4GHz and 5GHz spectrum."

It's a Network Card, not a Router.

It seems the system was having wireless issues before you wiped and installed the new operating system. Is this a brand-name system? Laptop? Did you download the NIC driver from the system builder's website or direct from Intel?

Sometimes the Intel driver will not work properly and you would need a modified driver from the system builder.

It may simply be the case that the wireless NIC is faulty and no amount of software fixes will resolve the problem.

Goin' Fishin' (Some day)

Report •

December 21, 2009 at 16:19:08
the system is a Compal HEL81 notebook.

The adapter worked prior to wiping it, but it was sporadic. the connection kept dropping.
Part of the issues it had prior to the reinstall was that the system was loaded with trojans and a number of other things... doubt that was a related problem, though

Report •

December 21, 2009 at 16:30:39
See the following for drivers:
There's one called Wireless Select Switch Utility. Might be what you need

Goin' Fishin' (Some day)

Report •

Related Solutions

December 21, 2009 at 16:56:42
doesnt want to install. gives me an error:

1607: unable to install Istallshield Scripting Runtime....


Report •

Ask Question