Solved i don't find any network adapters while searching for mac id

December 18, 2012 at 02:27:42
Specs: Windows 7, core i3
i am working with windows 7 ultimate OS, lenovo g580 . While i tried to connect lap to WiFi network , their is need for MAC id , so i tried with " getmac " , "getmac -v -fo list " , " ipconfig/all " ,commands .But it shows no adapters were found. please if you get any solution post me.

See More: i dont find any network adapters while searching for mac id

Report •

December 18, 2012 at 06:14:31
✔ Best Answer
First make sure the wireless adapter is NOT turned off (read your laptop instructions). If you are sure it is turned on, try re-installing the driver for your wireless adapter. You can download it from the Lenovo website:



Or select your country at top of page.

If none of the above fixes the problem, the wireless adapter may be faulty. Look in Device Manager to see if it is listed there. If it isn't listed then it's faulty.

Report •

December 19, 2012 at 11:26:51
thank you phil.

Report •

December 19, 2012 at 12:37:35
Once you have the adapter showing when you do a ipconfig /all you will see the mac address listed as the "physical address" in the ipconfig output.

BTW there is no "need for MAC id " when joining a wifi network so this bit you are confused about.

if the router is setup to do mac filtering this mac address has to be entered into the router before you can get wifi access.

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's

Report •
Related Solutions

Ask Question