Solved I cannot connect to the internet with my computer.

Hewlett-packard Hewlett packard hp g72-2...
March 22, 2015 at 17:53:31
Specs: Windows 7 Home Premium SP1, Pentium dual core 2.3GHz / 5.00 GB
This is a complex issue that started small but has gotten worse.

Initial problem: After several months of good internet connectivity, I began regularly receiving the error "windows could not automatically detect this network's proxy settings."

Solution: I did a hard reset of my modem, and there were no problems for about a week.

Recent problem: recently I began receiving several errors. These include "your broadband modem is experiencing connectivity issues", "windows can't communicate with the device or resource (primary DNS server)", and two that say something about IP address configuration.

What I have tried so far:

1. Connecting to the internet through my router via wifi
Result: No internet access "windows can't communicate with the device or resource (primary DNS server)"

2. Connecting to the internet through my router via Ethernet cable
Result: No internet access "windows can't communicate with the device or resource (primary DNS server)"

3. Connecting to the internet through my modem via Ethernet cable.
Result: No internet access "windows can't communicate with the device or resource (primary DNS server)"

4. Connecting to the internet through an unrelated public router via wifi.
Result: No internet access "windows can't communicate with the device or resource (primary DNS server)"

4. Restarting the PC, the router, and the modem in every possible order.
Result: No change

5. Calling ISP to have remote reset performed
Result: No change

6. Having technician from ISP come to check everything. He checked the lines inside and outside, replaced the Ethernet cables, replaced the modem, confirmed that everything shows a connection from their end, and confirmed that other devices can connect to my internet. It seems that something is wrong with my computer itself that is preventing me from accessing my internet.

Any advice would be greatly appreciated.


See More: I cannot connect to the internet with my computer.

Report •

#1
March 22, 2015 at 18:09:11
You might have already done this at sometime but just in case:
http://windows.microsoft.com/en-gb/...

Always pop back and let us know the outcome - thanks


Report •

#2
March 22, 2015 at 21:10:12
✔ Best Answer
Sometimes Proxy settings get turned on when your ISP does not use them. Set them to off and see if that makes a difference.

Sometimes you install an antivirus suite and it includes its own firewall but Windows includes its own firewall. The new AV suite should turn off the Windows Firewall but sometimes it does not. Possible solutions are to turn off Windows Firewall (in Services) or turn off/uninstall the other firewall from the AV (my preference). What antivirus program/suite do you have?

Check your software firewall to make sure that your browsers are listed as having access through it.

You have to be a little bit crazy to keep you from going insane.


Report •

#3
March 23, 2015 at 05:38:20
For Internet Explorer, Proxy setting is in:

Tools > Internet Options > Connections tab > LAN Settings button.

Always pop back and let us know the outcome - thanks


Report •

Related Solutions

#4
March 23, 2015 at 12:41:53
I have already tried the windows troubleshooter, and made sure proxy settings are turned off. I will have to check to see if there is interference from my AV software.

Report •

#5
March 23, 2015 at 13:36:56
I tried turning of the windows firewall and that didn't help. Then I tried turning off my antivirus and that also did not help.

Report •

#6
March 23, 2015 at 13:50:20
I just ran "netsh int ip reset c:\resetlog.txt" and then rebooted my PC. That did not help either.

Report •

#7
March 23, 2015 at 14:12:26
I set both ipv4 and ipv6 to automatically obtain DNS and IP address. That did not help either.

Report •

#8
March 23, 2015 at 14:17:49
I fixed it finally.

Report •

#9
March 23, 2015 at 15:21:04
Can you give us a brief indication of the fix please?

Always pop back and let us know the outcome - thanks


Report •

#10
March 23, 2015 at 15:56:17
Yes please, any details may one day help someone else.

You have to be a little bit crazy to keep you from going insane.


Report •

#11
March 24, 2015 at 17:13:33
After I changed the ipv4 and ipv6 to automatically obtain the DNS and IP Address, I used ipconfig in the command prompt to release and renew my IP address. After that I think I might have also reset the modem so it could pickup the new settings. After that I could connect.

Report •

#12
March 24, 2015 at 17:22:06
Thanks very much for that concise and clear explanation. It might help others who google into this post. Nicely done.

Always pop back and let us know the outcome - thanks


Report •

#13
March 24, 2015 at 17:33:00
After I changed the ipv4 and ipv6 settings to automatic. I released and renewed my IP address with IPConfig and reset the modem. After that it worked.

Report •

#14
March 24, 2015 at 17:54:24
Thanks again and good luck with it.

Always pop back and let us know the outcome - thanks


Report •

Ask Question