How to connect laptop to E3000

Cisco Linksys e3000 high performance wir...
January 6, 2011 at 15:30:48
Specs: Windows Vista, AMD dual core 2 GB
I have a new Linksys E3000 router.
Everything I wire to it works flawlessly
My iPad works correctly
My older laptop works correctly
My newer laptop absolutely refuses to connect through it.

The laptop sees the router and when I key in the network name and passcode it appears to connect but I have no internet connectivity.
I worked with Cisco's support chat line but as soon as they learned that there was an Atheros
AR5007 wireless port in the laptop they said "Sorry can't help you!"
I did an internet search today and found that there are definite problems getting this port and router to play nicely together but some folks are apparently succeeding. What do I need to set on the laptop or on the router to get the laptop to work without breaking the connection to the iPad.

Is it easier in the long run to just buy a new network port??


See More: How to connect laptop to E3000

Report •

January 7, 2011 at 07:46:09
Try statically assigning the TCP/IP information to the wireless network interface of your laptop before you do anything else.

First, connect to your router's management interface and check the "DHCP Scope". You want an IP that is not in the scope so as to avoid any chance of a duplicate IP address. Typically, the DHCP scope configured on most SOHO Routers looks like this: to

So if your scope matches that, an IP like: would work nicely since it's outside the DHCP scope. The other TCP/IP settings you need are; Subnet Mask, DNS, and Default Gateway.

The DNS and Default Gateway IP's would be the LAN IP of the router (the same IP you type into your web browser to connect to the router's management interface) and you will use the same subnet mask as what's configured on the LAN side of your router.

So, let's say your router's LAN IP is and the subnet mask is: and the DHCP Scope is what I said above here's the settings you would deploy on your laptop's wireless NIC:


Once you've statically assigned TCP/IP settings approrpriate to your LAN, then try connecting the laptop. If it works, don't mess with it any more and enjoy. If that doesn't work, get back to us here and we'll see what else we can come up with.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***

Report •

January 7, 2011 at 08:37:38
Tried it. No change!

Another possible clue and something I find inexplicable is that
even though the laptop will connect in some sense to the router
it can't or won't ping it.

When I run ping from the laptop the first packet
is lost and the remaining three are echoed from itself.

This behavior is independent of whether it is "connected" to
the router


Report •

February 1, 2011 at 15:57:28
Any luck Tom as I have the very same problem. I am at my wits end on how to solve this problem.

Report •

Related Solutions

February 1, 2011 at 16:07:19
post the results of an ipconfig /all when set to use dhcp
make sure the windows firewall is set to allow file and print sharing /not blocking the local subnet

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's

Report •

February 1, 2011 at 20:12:50
It was suggested elsewhere that I get an updated driver. Easier said than done :(
I didn't find any downloadable drivers at the Atheros site and almost all of the drivers sites I located wanted to charge me $29.95 and examine my system and update all the drivers. Not what I wanted. I finally found a current driver on a site in central Europe which I could download for free and which fixed my home problem.

Last week my wife and I took a mini vacation to the coast and that same laptop would not connect to the motel's wifi. Same symptom. I give up and will replace the wireless board in the laptop.


Report •

April 14, 2011 at 02:33:53
Just FYI, it's only affected if your trying to use WPA or WPA2 security. You can connect normally using WEP. I've been battling with this issue for weeks on and off. BTW I've tried all the ipconfig release renew, static settings, updated my Atheros AR5007 driver and firmware upgrade on the E3000. None of that helped... :(

Report •

April 14, 2011 at 08:17:10
Things are finally better!

Getting the new driver fixed my problems with attaching to my home network
but the first trip we took the laptop didn't attach to the motel wifi.

I took the laptop in to my local computer shop to get a new network interface but
the only card he had was an Intel card and wouldn't work with the AMD processor
in my HP laptop.

Chris, the computer shop guru, disabled the HP wifi management tool which only
means that I need to use the Windows wifi management which actually works just

On a recent cross country trip, we drove from Oregon to Arizona, Georgia,
Tennessee, back to Arizona and home, there was only one motel where I
had any difficulty connecting and in that facility running the network
troubleshooter reset the DNS and things were fine. The combination of the
new driver and disabling the HP wifi manager seem to have cured all my
previous problems.


Report •

Ask Question