How to access an Icy Box via FTP

Raidsonic / Ib-nas901
January 2, 2009 at 06:03:37
Specs: Windows XP, QUAD 2.66GHz / 4GB
Hello there,

This is my first time posting here at I would really appreciate if anyone can help me out with this. Basically I have just purchased an ICY BOX (IB-NAS901), of which I locally installed successfully. What I am trying to do is to access it remotely from external locations via FTP. I am behind an Edimax wireless router (BR6204WG) set on a default IP Address of, whilst on the other hand the ICY BOX is set on I did some research in to several forums but I got mixed up. Some mention that you have to set a virtual server on the router; some say that all you have to do is to open port 21 on the NAS IP Address and so on. I did try both of them but with no success yet. Can anyone help please?

I’ll thank you in advance guys.


See More: How to access an Icy Box via FTP

Report •

January 2, 2009 at 06:32:57
You have to configure port forwarding in your router.
Src Port: 21
Src Address: any
Dest Port: 21
Dest Address:

The main question is, how did you figure out your public IP address, to connect to your NAS?
Are you using a service like or dyndns?

Then you have to connect to your NAS by using e.g. port 21 in your ftp client.

Report •

January 2, 2009 at 06:38:12
First make sure that you can access it internally. Open a command prompt on one of the PCs and type:

ftp press enter

Does it give you a login prompt? If so, were you able to login?

If all that worked and you want to try it from outside your network, you can't use that IP address. You have to test it with your external IP but even if you have it setup correctly, that IP is subject to change. You may have to use dyndns or another solution.

Report •

January 2, 2009 at 23:08:28
I did register with dyndns and when tried to access the ftp via command prompt it says that it is now connected and asked for a username. I enter the correct user name and seem to be accepting it because then it says 331 password required. But when I enter the correct password it says 530 permission denied login failed.

Report •

Related Solutions

January 3, 2009 at 03:32:04
In this case, you have to check the permissions for that user in the settings of your ICY BOX.

Report •

Ask Question