Solved how i can use appropriate net framework?

February 15, 2017 at 04:15:22
Specs: Windows 7
i need a appropriate net framework , last fer three days it is showing some net framework error, so it plz

See More: how i can use appropriate net framework?

Report •

#1
February 15, 2017 at 05:08:27
.NET framework is designed to be backwards compatible as much as possible.

Have you tried uninstalling all versions then installing the latest compatible one with your operating system? Windows 7?

message edited by btk1w1


Report •

#2
February 15, 2017 at 13:32:17
Run Windows Update.

Report •

#3
February 15, 2017 at 17:27:28
✔ Best Answer
.NET is backwards compatible withing the same major version. If the program was written with .NET 3.x It may not run in .NET 4.x That's why there can be more than one .NET version on your system; .NET 3.x, .NET4.1.x, .NET4.5.x etc..

https://msdn.microsoft.com/en-us/li...
Not all versions of .NET run on a specific Windows version.

Download .NET framework version:
https://www.microsoft.com/net/downl...


Report •

Related Solutions

#4
February 16, 2017 at 07:38:45
Thanks for clearing up the backwards compatibility for the OP (and myself) sluc.

I hope their issue is resolved.


Report •

Ask Question