Click here for important information about

Help needed setting up home FTP server.

August 14, 2012 at 17:33:31
Specs: XP
Hi there everyone,

Win XP machine
Linksys WRT320N

I've tried following a lifehacker post for both Serv-U and Filzilla home FTP server setup but both attempts failed.

I tried initially to connect using standard port from outside the local network, but got a welcome message different than the one set in the application:

" 220 RASB NAT FTP server (MikroTik 4.17) ready"

and login failed, so I assumed that my ISP is rerouting the port. So in both attempts, I changed the port to 2121, forwarded the port in my router to the proper machine and tried it again. Both attempts resulted in a connection refused error. Trying inside the network via the 192 ip results in a successful connection, so my issue is only when connecting outside the local network.

I'm just not sure where to go from here. Could someone guide me on how I might troubleshoot my setup?

Any help would be greatly appreciated!

See More: Help needed setting up home FTP server.

August 15, 2012 at 04:29:35
so I assumed that my ISP is rerouting the port

You assume wrong. Not within the ISP capabilities.

Makes sure that the port you are trying to connect on is the same port as the server is listening and and the same one that the Router is configured to forward to the server. This is usually port 21. If for some reason you change this port, there are three places it needs ot be adjusted. The server, the client and the router.


Report •

August 15, 2012 at 07:25:04
You assume wrong. Not within the ISP capabilities

Rerouting isn't, but completely blocking is. If all settings are correct as per StuartS's response, contact your ISP and find out if they block port 21. It's possible they are to prevent you from setting up your own ftp server at home.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***

Report •

August 15, 2012 at 14:21:09
When you changed the port to 2121 did you also try connecting to 2121?

As a simple test try connecting to it via your smart phone over 3G and see if that works. If it does, then it's quite possible that your ISP is blocking it. You may also want to try a port scan of your external IP address and see if you can see the FTP server listening.

Also, what are you actual requirements? Why do you need an FTP server? It may be worth exploring better, more secure alternatives.

Just curious, if you login to your routers webGUI what IP address does it show as your WAN address? Don't post the entire thing here, just post the first 2 octets.


Report •
Related Solutions

Ask Question