Getting a limited or no connectivity error

Hewlett-packard Broadcom netxtreme gigab...
September 8, 2010 at 12:38:37
Specs: Windows XP
Following a recent install, my laptop now cannot access the internet wired or wirelessly. I tried to do a recent restore point from a previously working backup and that did not work. The network will not assign an IP address and registers as a IP address. I went in my device the "Non-Plug and Play Drivers" I show the following errors. "AVG AVI Loader Driver x86", "AVG8 Network Redirector", "Bytemobile Kernel Network Provider", "IP Network Address Translator", "Serial", and "TCP/IP Protocol Driver". Please note, I previously tried to restore network settings with a Winsock reset program and that failed to work. I also went to Services.msc and tried to start the DHCP Client as instructed in a thread but I get a Error 1068. (Could not start the...) Please advise.

See More: Getting a limited or no connectivity error

Report •

September 8, 2010 at 12:50:11
I would suggest start by uninstalling/removing all of AVG.

Disable the wireless until you get the wired working again.

Confirm in device manager the wired card is installed with no explaination point.
Confirm in network properties the wired card has microsoft client/tcp-ip installed and is set to get an ip address.

You get a ip address when autoconfigure is not checked and the nic wasn't able to get a response to the dhcp request for an ip address.

Report •

September 8, 2010 at 13:21:37
Thx for the prompt reply...I had previously uninstalled AVG before my current restore point. Now in the "Add or Remove Programs" it shows on the list but when I try to uninstall it again it has an uninstall error.

I confirmed my network adapter card (Broadcom NetXtreme Gigabit Ethernet) has no yellow exclamation points.

Moreover, the wired adapter in network settings I confirmed is set to "Obtain an IP address automatically" and that the wired card has microsoft client/tcp-ip installed

Report •

September 8, 2010 at 13:33:59
I did notice however in snooping around other threads, when I go to Start, Run, type Msinfo32, and then click OK. Expand Components, expand Network, and then click Protocol.
I have more than 10 names in the Winsock2 key.

I show the following names...

RSVP UDP Service Provider
RSVP TCP Service Provider
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD NetBIOS [\Device\NetBT_Tcpip...

48 more instances of MSAFD NetBIOS [\Device\NetBT_Tcpip...
MSAFD nwlnkipx [IPX]
MSAFD nwlnkspx [SPX]
MSAFD nwlnkspx [SPX] [Psuedo Stream]
MSAFD nwlnkspx [SPX II]
MSAFD nwlnkspx [SPX II] [Psuedo Stream]

The thread states that If the names are anything different from those in this list (see the first 10 names), the Winsock2 key is corrupted, or you have a third-party add-on, such as proxy software, installed. If you have a third-party add-on installed, the name of the add-on will replace the letters "MSAFD" in the list.

If there are more than ten sections in the list, you have third-party additions installed. If there are fewer than ten sections, there is information missing.

Could this be a clue?

Report •

Related Solutions

September 8, 2010 at 13:34:26
"following a recent install" does this mean OS or a program install?

what are you connecting to? router? modem?
when you connect to the device the lights go green?

update: you have netware client installed. Are you connecting to a netware server?

Report •

September 8, 2010 at 13:50:09
I forgot to mention I have another laptop and it connects to my home network just fine--both wirelessly and wired. Btw, my network hierarchy is as follows...modem, then router(linksys)

My install was a program install. It was an excel spreadsheet converter. I got it off the internet off a 3rd party site. Wondering if it had malicious code

Report •

September 8, 2010 at 13:53:05
when you connect to the router the lights go green at both the nic and the router?

if yes then we have a good physical connection and the problem is logical [software]

if you are not connecting to a local netware server nwlink and all other protocols except tcp/ip should be removed. It is OK to have under tcp/ip wins tab to have netbios over tcp/ip set at default or enabled.

Report •

September 8, 2010 at 14:14:48
Yes, the lights are indeed green on both the nic and the router.

(I was not aware I had netware but you are correct I do not need it. I only use the laptop for local, home use.)

Could you please expand on how I remove all other protocols with the exception of tcp/ip?


Report •

September 8, 2010 at 14:21:53
Sure. Right mouse click on My Network and go to properties. Right mouse click on local area connection properties.

This opens a box that has a number of things listed like microsoft client, tcp/ip etc.

Remove nwlink
Remove netware client

Anything else here beyond?

client for microsoft networks
file and printer sharing
QoS packet scheduler [you may or may not have this]
Internet protocol

Report •

September 8, 2010 at 14:28:23
I show NWLink NetBIOS and NWLink IPX/NetBIOS Compatible Transport Proto...

Should I uninstall or uncheck.

FYI...Aside from the former I have QoS Packet Scheduler, Microsoft TCP/IP version 6 and Internet Protocol (TCP/IP)

Report •

September 8, 2010 at 14:35:21
Actually, I went ahead and uninstalled netware and rebooted.

Report •

September 8, 2010 at 14:44:30
Good. Those two need to go also.

What happens is windows protocol binding order can get messed up. I suspect instead of talking tcp/ip as primary windows listed one of the others as primary.

Please post the results of an ipconfig /all for review. Thanks

Report •

September 8, 2010 at 14:46:47
With a reboot completed...I verified in Device Manager that there are still exclamation points for TCP/IP Protocol Driver, Serial, IP Network Address Translator, Bytemobile Kernel Netwok Provider, AVG8 Network Redirector and AVG AVI Loader Driverx86

Report •

September 8, 2010 at 14:53:25
When I type in ipconfig /all in the command prompt I get an error message...

Windows IP Configuration
An internal error occurred: The request is not supported.
Please contact Microsoft...
Additional information: Unable to query host name.

Report •

September 8, 2010 at 15:23:44
Registry really sounds hosed.

You can try deleting everything in lan connection properties then delete the nic in device manager as well as these items with exclaimation points. Reboot. Go in and then readd MS client and tcp/ip. See if that will work.

if not its time for the hammer: do a repair install of xp. This is not a new install. A repair will refresh the OS files and some registry keys without messing with your data.

Report •

September 8, 2010 at 15:38:25
Lol...I suspected. So to recap, I am deleting

Client for Microsoft Networks
File and Printer Sharing for Microsoft Networks
QoS Packet Scheduler
Microsoft TCP/IP version 6
Internet Protocol (TCP/IP) - no unistall option avail on connection properties

My Network adapters (Broadcom NetXtreme Gigabit Ethernet and Broadcom NetXtreme Gigabit Ethernet - Packet Scheduler Miniport) and ingnoring my 18 other adaters for now i.e. wireless adapter etc. correct?

Report •

September 9, 2010 at 08:11:26
Yep. that sounds like a plan

Report •

Ask Question