gateway issue in MPLS network

May 7, 2010 at 11:31:15
Specs: all
Hi everybody

First, Thanks for your time.

Second, We have 3 points in 3 city connected through MPLS network.

We have installed 3 Cisco 878 Modem-Router in each location.

The problem is:
When I want to ping (access) a computer behind any of these routers I MUST add my router’s IP address in gateway of my clients LAN cards.

If don’t, I can not access it anyway! This issue caused me a lot of problem on my ISA machine. (Multi gateway)

You may see a test trace route below (from my router to a pc behind another router) and also a copy of my router’s show run.


Router1#traceroute 192.168.20.10

Type escape sequence to abort.
Tracing the route to 192.168.20.10

1 172.17.7.61 24 msec 24 msec 28 msec
2 217.218.188.25 36 msec 36 msec 36 msec
3 217.218.185.18 36 msec 36 msec 36 msec
4 * * *
5 172.17.6.126 36 msec 32 msec 32 msec
6 192.168.20.10 36 msec 32 msec 36 msec

As you can see in trace route, the packet does not go through my Vlan1 IP address, it goes through the IP of my ATM0.


Current configuration : 1198 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
dot11 syslog
ip cef
!
!
ip name-server 192.168.10.15
!
!
!
username admin privilege 15 secret 5 ***EDITED***
!
!
archive
log config
hidekeys
!
!
controller DSL 0
mode atm
line-term cpe
line-mode 2-wire line-zero
dsl-mode shdsl symmetric annex B
line-rate auto
!
!
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface ATM0
ip address 172.17.7.62 255.255.255.252
no atm ilmi-keepalive
pvc 0/35
encapsulation aal5snap
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 192.168.10.1 255.255.255.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.17.7.61
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end

Waiting for your help.
Regards.


See More: gateway issue in MPLS network

Report •


#1
May 7, 2010 at 14:46:53
Are these label switching/edge routers?
You really running DSL/BRI/ATM interfaces?
That output looks like routing and that is not what mpls is about.

I don't have a MPLS yet but have been considering it for our new central site.

http://en.wikipedia.org/wiki/Multip...

http://www.ciscopowerednetworks.org...

Last link has an example at the end.

if you telco provider set this up you should be talking to them. You should not need multiple gateways. MPLS has "neighbors" and I suspect its the mpls config that is at fault.


Report •

#2
May 7, 2010 at 22:19:44
Thanks for your reply.

It's just a layer 3 configuration for my end point routers.

I Just use DSL and ATM interfaces, not bridge.


as I said the problem raise when I do not enter gateway ip address in LAN of clients,

any suggestion??


Report •

#3
May 8, 2010 at 08:15:58
talk to your mpls provider and get them to properly configure the mpls network. layer 3 is your end points which talks to the layer 2.5 label routers. only gateway you should need is your local one. clearly the mpls network isn't routing correctly and you can't correct this at layer 3.

Report •

Related Solutions

#4
May 8, 2010 at 12:12:18
Thanks for your help.

the problem solved with just writing a static route on machine!


Report •

#5
May 14, 2010 at 13:17:07
You should not have to add a static route at the PC level. All you need a default route to your ISP and the routing to your network (internal) should not be a problem.

Adding a static route is a band aid fix and can you add a static route for 50 machines if you had too? Too much administration.

You should really check with your ISP.


Report •


Ask Question