Ethernet not working after wireless set-up

Trendnet Tew-639gr n gigabit wireless ro...
March 10, 2010 at 08:17:03
Specs: Windows XP

I had a linksys wired router hooked up to my laptop and it worked fine. I bought a new TrendNet TEW-639GR wireless router to replace it and followed the following steps:

1) I replaced the linksys with the new trendnet and hooked up as before

2) I checked my laptop and it worked fine via the ethernet cable.

3) I setup the wireless with WPA2 and was able to connect to the wireless network. I disconnected the ethernet cable to test that the wireless worked and it did.

4) Later in the day, I retried connecting the ethernet cable and got a "Limited or no connectivity"

5) I tried wireless again and it still worked perfectly

6) I restarted the laptop, router and modem but that did not fix it

7) I checked ipconfig and I was getting a 169 ip on the ethernet, the wireless would get the right 192 ip

8) Given that the router had worked properly initially, I reset it back to factory defaults by pressing on the reset button for 30 seconds

9) I tried to connect via ethernet again and it did not work, same ip problem

10) I tried wireless (now unencrypted) and it still worked

11) I checked the properties of my LAN connection to make sure it was set to automatically get IP and DNS, it was set correctly

12) I do now know what to do!

Today I will try with another laptop to isolate the problem. One more thing, I have a NAS connected to one of the LAN ports of the router and is accessible via the wireless network.

Any ideas?

See More: Ethernet not working after wireless set-up

Report •

March 10, 2010 at 09:51:11
Simply try to disable the wireless network card, when you will use wired connection.
Otherwise, if both network cards are connected, windows gets in trouble, because of the two network card, connected to the same network (e.g. 192.168.1.x) and both gets the routers ip address as default gateway.
Btw, to have two network cards connected to the same network did not really make any sense.

Report •

March 10, 2010 at 09:55:12
I tried disabling both wired and wireless and then enabled the ethernet ONLY, it still did not make any difference. I will try this once again when i get home

Report •

March 10, 2010 at 09:58:26
You should also check, whether the computer got a valid ip address of the router.
Click Start / Run and type in CMD
At the command prompt type
ipconfig /all

This should show something like 192.168.x.x as ip address for your computer.

Report •

Related Solutions

March 10, 2010 at 10:07:40

if i do ipconfig, my computer gets a 169 IP address and not the correct 192.168 address. The default gateway is also not set i believe.

If i try to ping my router at, it fails as well.

(On wireless I get the correct IP for my computer as well as the working ping)

Report •

March 10, 2010 at 13:50:54
1. Try to change the cable, maybe cable is corrupt.
2. Try to use another port for the workstation at the router.

Don't forget to reboot, when you make these changes.

Report •

Ask Question