Copy Port Config

Nortel 4548gt-pwr ethernet routing switc...
July 7, 2010 at 19:08:58
Specs: IOS
Can anyone please kindly share the command to copy a ports config to another port, Basically I need a command to be able to make a port work be it a phone or a PC is plugged into the port on the switch...

thanks in advance.


See More: Copy Port Config

Report •


#1
July 8, 2010 at 05:21:22
What model switch are you using and which version of the IOS does it have?

As far as I know there's no way to copy a port config from one port to another. You just have to config the port the same.

Also, how you config a port, or ports, depends on which IOS version your switch has.

On 12.0 you have to do it a single port at a time. With 12.1 you can do the "range" command to apply a config to a range of ports at one time.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***


Report •

#2
July 9, 2010 at 09:47:48
Thank you so much Curt for taking the time to respond, I will configure them indivdually, I thought there might be an easier way....!

Thanks again.


Report •

#3
July 9, 2010 at 09:58:42
Wishful thinking that! LOL

Do check your IOS version. If you have v12.1 or newer you can use the "range" command.

From global config it would look something like this to configure ports 2 through 12 with VLAN 5 (for example):

Switch (config)#int range fa0/2 - 12 (enter)
Switch (config-if-range)#switchport access vlan 5 (enter)

If you're configuring a bunch of interfaces with the same config, this is quicker than copying one at a time too.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***


Report •

Related Solutions

#4
July 9, 2010 at 12:30:22
I forgot to add.........

If you have an older version of the IOS (ie: v12.0 or older) then you don't have the "range" command and have to configure one port at a time. I found it's not too too time consuming to do thanks to the switches keeping a history of commands. Once you've added a VLAN to the first port, you can use the up arrow key to go back through commands and then only have to change the interface number.

See below example:
First go into global configuration mode and then enter the command to edit the first port you wish to configure:

Switch(config)#int fa0/2

Add the VLAN to the interface

Switch(config-if)#switchport access vlan 1

hit the up arrow key twice and then backspace to erase the number 2 and enter 3 (or whichever interface you wish to add that VLAN to next)

Switch(config-if)#int fa0/3

Up arrow key twice to bring up the switchport command and just hit enter unless you want to add a different VLAN to this port, then backspace, type in new VLAN number, then hit enter....and so on until finished.

Switch(config-if)#switchport access vlan 1
Switch(config-if)#int fa0/4
Switch(config-if)#switchport access vlan 1
Switch(config-if)#

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***


Report •

#5
July 9, 2010 at 18:45:19
You are so awesome Curt!!

Thank you so much!!


Report •

#6
July 12, 2010 at 17:40:13
Hi Curt,

Hope you get this message. I wanted to let you know what I am trying to accomplish hoping that will help you help me better? oh by the way I am running IOS 12.2 on these switches and they are 3750G 48 ports cisco switches so basically what I am trying to do is make the ports usable by cisco POE phones and computers...hope that makes sense...? please see the example config below;

!
interface GigabitEthernet3/0/5
description Phone - CLAN & TLAN
switchport access vlan 20
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport trunk allowed vlan 20,40
switchport mode trunk
switchport voice vlan 30
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast


thank you in advance!


Report •

#7
July 12, 2010 at 17:59:25
So I am ultimately looking for commands to configure these ports to use both cisco phones and computers.

Thanks again in advance!


Report •

#8
July 13, 2010 at 05:24:24
You should not be making the ports trunk ports. A trunk port is used to interconnect network appliances and carries all VLAN's with VLAN 1 as the PVID.

Each port should only have one VLAN assigned to it. There is only one exception to that (other than a trunk port) that comes to my mind and that's if you can plug a computer into your VoIP phone.

We can with ours and if 20 is VoIP and 40 is Data I would assign both to the port and make 20 the PVID since it's the device plugged directly into the port (the PC plugs into the phone).

Setting up a port for VoIP:

interface GigabitEthernet3/0/5
description Phone - CLAN & TLAN
switchport access vlan 20
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast

Setting up the same port for Data:

interface GigabitEthernet3/0/5
description Data
switchport access vlan 40
spanning-tree portfast

Finally, setting up the port for both VLAN's:

interface GigabitEthernet3/0/5
switchport access vlan 20
switchport access vlan 40
mls qos trust device cisco-phone
mls qos trust dscp
spanning-tree portfast

The above are examples only.

To be honest, I believe you're in over your head here and should probably hire a professional.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***


Report •

#9
July 13, 2010 at 09:28:04
Thank you so much Curt, I agree that I might be in over my head...but how do we grow if we don't challenge ourselves...with your kind help and other wonderful people out there and some studying, I think I am well on my way!

Again,I thank you so much for taking the time to school me!


Report •


Ask Question