Cisco linksys router port 80 open but notwork

Dell Inspiron 1545
March 27, 2011 at 20:33:49
Specs: Windows XP, 1.995 GHz / 2008 MB
I have port 80 open and there is nothing on my computer blocking it as I can see my site when U type my pc local ip address.


right now I have port 80 set to both but nothing is showing up on my domain. if I change it to udp and I type in my domain it will take my to my routers config page. If I change it back to both or tcp my website will not work. It all stopped working about a few weekends ago. my VPN won't even work now.

Its like my router doesn't want anything else to listen on my domain other then the config page of the router if port 80 is set to udp. Funny thing is if its set to 80:udp:192.168.1.90 or 80:udp:192.168.1.20, etc it will only allow my config page to be seen no matter what local ip is selected. Its also not my ISP as I have comcast and it has worked in the past. I even asked a few days ago and they said that the port is open automatically.


So did my router lose it or is something going on?

Also my website was hacked around the same time and left enval(decode_base64(.....==)) in all of my php scripts which I fixed.


See More: Cisco linksys router port 80 open but notwork

Report •


#1
March 27, 2011 at 21:02:54
Have you set up the router, to forward tcp port 80 to your local ip address of the server?

Click Here on HowTo ask good Question to get best Help
Let us know, if the problem is solved !!!


Report •

#2
March 28, 2011 at 09:30:46
yes I have. I don't know whats up with it.

Report •

#3
March 28, 2011 at 09:53:42
Are you trying to access your server from inside your LAN, by using the domain name?

This might be a problem.
From inside you LAN, access the server by it's ip address.

Click Here on HowTo ask good Question to get best Help
Let us know, if the problem is solved !!!


Report •

Related Solutions

#4
March 28, 2011 at 10:07:46
I'm trying to access it outside my network. It worked in the past but then all the ports stopped working. I didn't change anything on my server and it is brodcasting when I check my servers local ip address. The ports I need are opened and are forwarded to the correct local ip for my server. Its just not working on my isp ip or my domain name.

and if I change the port 80 type to udp and I try to use my domain name, it will display my routers configuration page instead. The funny thing is though. If I change the local ip for the port 80 to what ever, even if its not my servers ip it will still display my routers config page if I leave it as udp.

So I have no idea whats going on ><


Report •

#5
March 28, 2011 at 13:01:18
Then you simply have to change the port for the web configuration interface to e.g. 88 or you have to disable routers web configuration interface for the internet.

Click Here on HowTo ask good Question to get best Help
Let us know, if the problem is solved !!!


Report •

#6
March 28, 2011 at 14:51:41
Fixed it was something on my end of the server. Updates vertrigo back down to 2.21 and now it works. Odd though because 2.23 was still broadcasting and I could still see my site if I type in my local ip for that server.

Report •

#7
March 28, 2011 at 18:07:18
This makes no sense.
While you're accessing the server from the internet and you've got the routers web interface instead of your server, it has surely nothing to do with the version of the HTTP server.

Also when you type in the local ip of the server and you are able to access it, that does not mean, that you are also able to access the server from outside your local network.

Click Here on HowTo ask good Question to get best Help
Let us know, if the problem is solved !!!


Report •

#8
March 29, 2011 at 12:31:14
I know I thought the same thing and I can access it outside my network because I've done it before. I couldn't access it outside my network untill I updated my HTTP software. so I don't know what happaned

Report •

#9
March 29, 2011 at 13:50:45
Anyway, it works. And that's the main thing.

Click Here on HowTo ask good Question to get best Help
Let us know, if the problem is solved !!!


Report •

Ask Question