Solved Can't stream Netflix on my samsung BD-D5100 Bluray player

September 18, 2012 at 16:29:58
Specs: Windows 7
Not able to run netflix through my samsung BD-D5100 Bluray. All the information from the Internet states that when setting up Netflix through your Bluray an authorization code would be given on the Bluray, and all you need to do is plug in player to router, get on your computer put authorization code in your netflix account and wallah your streaming videos and shows in no time. I'm calling Bulls---. I got no code, and as a matter of fact have no Internet connectivity to my Bluray player. When I go to my Bluray setting tab and run a network test the MAC Address checks out but fails when it gets to IP Address. My Bluray is plugged directly into my router and it still shows no Internet connection between the two, even though my x-box 360 has no problem nor does my computer. When looking at my network settings the IP Addresss boxes all have numbers in them, the Subnet Mask boxes two of four boxes have numbers the others are zeros, the Gateway boxes are all zeros, and the DNS Server boxes are all zeros. I read many of the posts in this forum and all problems seem pretty similar to mine. Regretfully I bought a samsung Bluray and a lot of posts said that netflix won't work on my player. I'm not extremely savy with these things so i'll need step by step advise. If you have a answer to my problem I would really appreciate as my girlfriend and I are trying to stream Breaking Bad. Great show by the way. Thanks in advance.

See More: Cant stream Netflix on my samsung BD-D5100 Bluray player

Report •

September 18, 2012 at 16:53:49
You are not getting code because you are not connected to the internet with the blu ray. o.o.o.o is a broadcast to get an IP address, so you are not receiving one from the router. Have you tried another cable from the router to the blu ray? Is there a firmware update you must do for the blu ray player? Without an internet connection it's not work.

Report •

September 18, 2012 at 17:19:27
First off Thanks for responding so soon. I just tried another ethernet cable(a brand new one) from the router to the bluray with no change in connectivity to the player. Re-ran the same network status checks as before and had the same results. I did try to do a software update prior to my first post which I forgot to disclose, and couldnt do the update because the Bluray couldnt connect to the internet. Not sure if this would be the same as the Firmware update you were describing. My curiosity arises only because I have numerous electronics connected to the same router and they work without a hiccup. I did read a forum that had a post that listed an IP Address, Subnet Mask, Gateway, and DNS server with numerical values in those boxes. And just for the sake of things I plugged those numbers into my settings and as far as the checks were concerned it got me past the IP Address check but failed on the subsequent Gateway Ping check.

Report •

September 18, 2012 at 20:18:22
✔ Best Answer
It seems you may need to manually configure the settings in the bluray player.
In order to do so you need to determine what those settings should be.
Eg. If your router has an IP of say and is allocating DHCP in the range of to 0.254 then your blueray should be getting an IP say 192.168.0.xx where the xx is a number between 2 & 254.
Subnet mask is usually

The important numbers to note are for Gateway & DNS and those should be the IP of the router. In this example

If you can manually configure the settings in the player simply put the router's IP in the Gateway & DNS boxes and you should be good to go.

Goin' Fishin' (Some day)

Report •

Related Solutions

September 18, 2012 at 20:42:05
Thanks to all that responded. RICHARD59 that was great advise and exactly what it needed. After reading the manual that came with the Bluray player, it does actually tell you what to do if the automatic connection fails. I went to my computer network settings opened the details tab, entered the proper numerical values in the Bluray settings and it did finally work. Thanks again for the help.

Report •

Ask Question