Solved Can't get Chromecast to work/PC to TV issues

Asus T3-m2nc51pv barebone system
December 5, 2013 at 04:24:02
Specs: Windows 8, Intel e5200 dual/2gb

I recently purchased a Google Chromecast as I wanted to broadcast items from my PC/other devices to my TV. I have all the relevant equipment, but the issue I'm having relates to the wifi network. Apparently my router (a BT Homehub 3.0) is not compatible? The Chromecast help suggests workarounds involving AP isolation but I can't find any way of disabling that in the settings. Another suggestion would be to change security settings to WEP but I am most reluctant to do so given its vulnerability. Does anyone have any ideas on this or should I just accept that it won't work and look at an alternative?

On that theme, it does seem daft that despite having an array of gadgets and gizmos, I can't work out how to put what is on my desktop in to my TV. They're both on the same network and I am able to view video stored on my NAS device (also on same network) so what am I missing? I don't have a HDMI out on my PC and although I could attach another windows laptop directly to the TV, I'd like to do it without adding more devices and cables!

See More: Cant get Chromecast to work/PC to TV issues

Report •

December 5, 2013 at 06:59:14
✔ Best Answer the top of my head my only suggestion would be to replace that router with one that will work with chromecast. They (chromecast) should be able to tell you which do work with their technology.

Downgrading your encryption to something that can easily be hacked (ie: WEP) is no more a solution than doing away with encryption altogether would be.

It matters not how straight the gate,
How charged with punishments the scroll,
I am the master of my fate;
I am the captain of my soul.

***William Henley***

Report •

December 12, 2013 at 05:15:01
Dear Curt - thank you for your reply and apologies for not having responded before now.

I think you are right and that is probably what I would have done eventually. I did though very briefly disable the security - it still didn't work so I re-enabled it. Just before throwing it at the wall, I tried once more and it worked!

Report •
Related Solutions

Ask Question