Cant connect to https sites with Firefox.

May 7, 2012 at 13:27:35
Specs: Windows Vista, vostro 1700
Happened yesterday when I started.

Connection is unsafe, ssl_error_bad_cert_domain is the pop up i get.

Hello I have a problem, hope someone maybe has an idea.

WIth Chrome it does work although a bit slow. With IE as-well.

Had the problem with FB as-well allthough that i could cancel with allowing it to connect.

Gmail doesnt.

Production Security Services and the certificates seem to cause problems.

Searched the internet; tried a scan, checked the date, activataed the SSL and TLS in the browsercertificates, the server and organisations names. Nothing worked.

Thanks in advance

See More: Cant connect to https sites with Firefox.

Report •

May 7, 2012 at 15:54:29
Are you saying that you're unable to visit a site due to service or certificates?

Did you check if your system time is correct? Wrong time and date can affect the service and certificates.

Make sure you're using SSL 2.0, SSL 3.0, TLS 1.0.
Make sure the setting is correct for "Automatic configuration" and "Proxy server".

After your problem has been fixed, please get

Report •

May 8, 2012 at 02:00:51
Hello thanks for teh answer,

Well I get the message unsafe connection and the reason is that the certificates are wrong. Self signed. At least that is the error message. I checked the date, and Ii am using SSL 3.0 and TLS 1.0. Certificates are set on automatic and I believeProxyservers are on automatic too.

Weird thing is i can get acces via Chrome or IE. Allthough computer is a bit slow in general with the internet.


Report •

May 8, 2012 at 07:55:46
Upgrade Firefox to version 12 and test again, see if it helps.

Scan your PC by using antivirus and anti-malware program with latest signature, this is to make sure the PC is clean.

Hope this helps.

Home Network & Wireless Network Help

Report •

Related Solutions

May 9, 2012 at 02:07:58
Whoops no, it was too early. It worked only once I had put some files from the temp file in the vault and then it allowed to connect. But now it doesnt anymore. Guess the problem is back again. :(

Thanks I solved it it were some trojans in the temp file.

Thanks for teh help everybody

Report •

Ask Question